NEWBIE - server error

when i launch the server , here is what i get :

C:\Documents and Settings\FRED> cd\rails\cookbook

C:\rails\cookbook> ruby script\server

=> Booting WEBrick…
c:/ruby/lib/ruby/1.8/yaml.rb:133:in load': syntax error on line 1, col 9:
adapter: mysql’ (ArgumentError)
from c:/ruby/lib/ruby/1.8/yaml.rb:133:in load' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:459:i ndatabase_configuration’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:181:i
n initialize_database' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:84:inprocess’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/initializer.rb:42:in
run' from ./script/../config/../config/environment.rb:13 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inre
quire’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_suppo
rt/dependencies.rb:147:in require' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/servers/web rick.rb:52 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inre
quire’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_suppo
rt/dependencies.rb:147:in require' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/server.rb:3 0 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inre
quire’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_suppo
rt/dependencies.rb:147:in `require’
from script/server:3

can you please help

C:\rails\cookbook>

its worth checking you’re YAML file for any Tabs - I think they don’t
like them IIRC

that helped solved the problem …

thanks…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs