Newbie-ish Capistrano/SVN Problem


#1

Hey guys,

I’m setting up my first Capistrano script and I’m running into an SVN
error I hadn’t seen before…

I’m using the default deploy.rb (except for changing some variable
values, of course). My first deploy went fine and the /current/
directory has everything as I expected on the target server. But,
when I went to deploy the second time, I’m getting an SVN error.

Cap output (some person detail removed to protect the innocent):

svn: Working copy ‘[[path_to_app_omitted]]/releases/20070326013138’
locked
** [out :: [[server_name_omitted]]] svn: run ‘svn cleanup’ to
remove locks (type ‘svn help cleanup’ for details)
command finished
*** [update_code] transaction: rollback

  • [update_code] rolling back
  • executing “rm -rf /[[path_to_app_omitted]]/releases/20070326013138”

I ran svn status on my working copy and there’s no locks. I ran svn
cleanup anyway, and it comes back with no output.

Anyone run into this before? Any common stuff I should be checking out?

Any thoughts/advice are appreciated…

Thanks,
Jonathan