Newbie installing EdgeRails: Error


#1

Hi,

I’m using Ruby-1.8.7, Rubygems-1.3.1, Rails-2.2.2 and
Rake-0.8.3.

But getting EdgeRails via

 rails test
 cd test
 rake rails:freeze:edge

yields

 rake aborted!
 wrong number of arguments (2 for 1)

What is wrong with this? The same error pops up with
Rails-2.2.1 in combination with Rake-0.8.1.

Hints appreciated!

Michael


#2

Can you freeze your current version?

rake rails:freeze:gems

I have the same Ruby version, Gem version, Rake, and Rails version and
I didn’t have any issues freezing Edge Rails. I’m on OSX Leopard.


#3

Can you freeze your current version?

rake rails:freeze:gems

Yes. This worked. But not rake rails:freeze:edge.

Anyhow, I’ve found the problem. It was the ruby version. Together with
rubygems-1.3.1, rake-0.8.3 and rails-2.2.2
the listed ruby versions behaved as follows:

ruby-1.8.6-p111 OK
ruby-1.8.7-p0 failed
ruby-1.8.7-p72 OK

So I guess you run ruby-1.8.7 with a patchlevel greater than zero.

Thanks for the hint!

Michael