Newbie installation problem: gem [command] --remote

Hi, i am a newbie to RoR. I downloaded Ruby 1.8.2-15 Windows installer
yesterday and trying to install following Curt H.’ Rolling with Ruby
on Rails(http://www.onlamp.com/pub/a/onlamp/2005/01/20/rails.html). My
OS is Win XP SP2 and the 1st step installation was fine.

D:\rg\xampp\ruby\bin>ruby -v
ruby 1.8.2 (2004-12-25) [i386-mswin32]

Next I was going to install rails remotely, but seems all the gem
command with --remote didn’t work. Here is the error message:

D:\rg\xampp\ruby\bin>gem install rails --remote --debug

D:\rg\xampp\ruby\bin>“D:\rg\xampp\ruby\bin\ruby.exe” “D:\rg\xa
mpp\ruby\bin\gem” install rails --remote --debug
Exception Errno::ENOENT' at D:/rg/xampp/ruby/lib/ruby/site_ruby/1.8/rubyg ems/config_file.rb:12 - No such file or directory - C:\Documents and Settings\Da niel/.gemrc Attempting remote installation of 'rails' ExceptionErrno::ENOENT’ at
D:/rg/xampp/ruby/lib/ruby/1.8/fileutils.rb:82
1 - No such file or directory -
D:/rg/xampp/ruby/lib/ruby/gems/1.8/source_
cache
Exception EOFError' at D:/rg/xampp/ruby/lib/ruby/site_ruby/1.8/rubygems/r emote_installer.rb:222 - End of file reached Updating Gem source index for: http://gems.rubyforge.org ExceptionErrno::EINVAL’ at
D:/rg/xampp/ruby/lib/ruby/1.8/net/protocol.rb
:197 - Invalid argument
ERROR: While executing gem … (Errno::EINVAL)
Invalid argument
removing D:/Temp/open-uri1844.0…done

D:\rg\xampp\ruby\bin>gem list --remote --debug

D:\rg\xampp\ruby\bin>“D:\rg\xampp\ruby\bin\ruby.exe” “D:\rg\xa
mpp\ruby\bin\gem” list --remote --debug
Exception `Errno::ENOENT’ at
D:/rg/xampp/ruby/lib/ruby/site_ruby/1.8/rubyg
ems/config_file.rb:12 - No such file or directory - C:\Documents and
Settings\Da
niel/.gemrc

*** REMOTE GEMS ***
Exception EOFError' at D:/rg/xampp/ruby/lib/ruby/site_ruby/1.8/rubygems/r emote_installer.rb:222 - End of file reached Updating Gem source index for: http://gems.rubyforge.org ExceptionErrno::EINVAL’ at
D:/rg/xampp/ruby/lib/ruby/1.8/net/protocol.rb
:197 - Invalid argument
ERROR: While executing gem … (Errno::EINVAL)
Invalid argument
removing D:/Temp/open-uri3952.0…done

The ZoneAlarm firewall was turned off already. Anybody know what’s wrong
with my configration? Thanks in advance.

Daniel

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs