Newbie help with Rails/Ruby. Totally lost! (Mongrel related, I think) 503 Errors

Hi everyone. I am on the verge of actually hiring someone to fix this
for me, but I hope it doesn’t come to that.

I have no experience with Rails/Ruby, but I do know my way around
computers in general.

I have two domains on one server (Hostingrails, I am beginning to hate
them more and more these days).

My secondary domain works 100% fine.

But for the past few days, my primary domain has not been working, it
has been giving me 503 Errors. I’ve opened a ticket regarding this, and
they told me to SSH into my server and reset “Mongrel”. I’ve done this
using the code they gave me; “mongrel_rails start -d -e production
-p13930”

It seemed to have worked, but the problem was still there. The log says
the error is something about:

“require’: no such file to load – dispatcher (LoadError)”

I’ve re-opened a ticket concerning this, and Hostingrails basically told
me that it is not their problem anymore and that it’s solely up to me to
fix it. Brilliant.

So I spent a good part of the day looking and changing things around
through SSH (probably wasn’t the greatest idea) but I still keep getting
503’d on my website.

However, I recently found out that my index file HAS to be index.html,
or it will not render the page. index.htm or index.php will result in a
503. If I set the index page to index.html, it worked. Which is strange,
my htaccess file allowed for all.

Another problem, I think I have inadvertently changed something in my
settings while I was SSH’d in. When I do “bundle install” it installs
the gems into my own private webspace, for example /home/mywebsite. But
I believe on my shared plan, all the rails/ruby/gems etc are all under
/usr/local/rvm/gems/ruby-1.9.2-p0/ which I don’t think I have access to.
How do I change the directory to the default one? For example, before
the error log said:

/usr/local/rvm/gems/ruby-1.9.2-p0/gems/activesupport-3.0.0/lib/active_support/dependencies.rb:239:in
`require’: no such file to load – dispatcher (LoadError)

Now it says:
/home/mysite/.gems/gems/activesupport-3.0.0/lib/active_support/dependencies.rb:239:in
`require’: no such file to load – dispatcher (LoadError)

I think that’s everything for now. Here are the rails installed on my
server by the host:

Installed at (3.0.0): /usr/local/rvm/gems/ruby-1.9.2-p0
(2.3.8): /usr/local/rvm/gems/ruby-1.9.2-p0

(again, I think my mongrel is looking in the wrong place, as my gems are
now being installed into /home/mywebsite/ instead of
/usr/local/rvm/gems/) Is it possible to someone reset the settings I’ve
changed back into my host’s default one?

Would anyone be willing to take the time and try and fix this with me? I
am pretty annoyed at Hostingrails, since I didn’t do anything to create
this problem, and they are outright refusing to help me. Why is my
primary domain getting 503 errors when my secondary domain works fine?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs