Newbie Four Days on Rails

Hi all,

Having successfully gone through Bill W.'s Tutorial ‘Rollining with
Ruby on [Instant] Rails’
I decided to tackle John McCreesh’s ‘Four Days on Rails’ Tutorial.

I changed the Rails version as recommended in the tutorial.

All went well until I entered the following command:-
ruby script/generate model category

I got:-

C:\InstantRails\rails_apps\ToDo>ruby script/generate model category
c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:149:in activate': can't activate act ivesupport (= 1.0.4), already activated activesupport-1.3.1] (Gem::Exception) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:37:inrequire_gem_with_
options’
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:31:in
require_gem' from ./script/../config/../config/environment.rb:57 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inre
quire’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_suppo
rt/dependencies.rb:147:in require' from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.1.2/lib/commands/generate.rb :1 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:inre
quire’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_suppo
rt/dependencies.rb:147:in `require’
from script/generate:3

Can somebody please point me as to what might be going on here?

Thanks in advance.

Stephen.

It looks like you’re using an older version of Rails, or, more
specifically, ActiveSupport. I’m not sure how to fix that (can you
install older versions of rails and dependencies?), but I hope that’s
at least a starting point. :confused:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs