New signal processing block

Hi,

I am trying to write my own signal processing block. I copied
gr-howto-write-a-block folder and I tried to change all the places
starting
with howto_… with my own package name and corresponding header,.i, and
cc
files in gr_howto_… folder.
However when I cd to the folder and start with ./bootstrap then
./configure
I got

checking pkg-config is at least version 0.18… yes
checking for GNURADIO_CORE… configure: error: Package requirements
(gnuradio-core >= 3) were not met:

No package ‘gnuradio-core’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables
GNURADIO_CORE_CFLAGS
and GNURADIO_CORE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

this error although my gnuradio-core folder is contained in gnuradio
folder.
Also when I try to do “make” I got

make: *** No targets specified and no makefile found. Stop.

this error telling that there is no makefile. I could not figure out
what to
do. Also I am using GSL library in my .cc file. Where should I tell the
SWIG
to link those specific libraries? such as -L/usr/local/lib -lgsl
-lgslcblas
-lm

Any help would be kindly appreciated.
Berk

View this message in context:
http://old.nabble.com/new-signal-processing-block-tp28190686p28190686.html
Sent from the GnuRadio mailing list archive at Nabble.com.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs