New release of WSS4R


#1

Hi everyone,

today a new release of WSS4R (www.rubyforge.org/projects/wss4r) is
available !
It is only a bugfix release.

There was an error that caused the following message:

c:/ruby/lib/ruby/1.8/i386-mswin32/digest.so: Class is not a module
(TypeError)

When starting the rails example with the one-click-installer.

Thanks to Sau S.!

— What is WSS4R?

WSS4R is a subset of a web service security standards implementation.
It’s
based on
soap4r and tested with Microsoft .NET WSE 2.0 and Sun Java JWSDP 2.0.
WSS4R
supports username
authentication, signing and encryption. It also has limited support for
actionwebservice / rails.

Currently, there is no documentation, but various examples for building
clients and servers with
ruby, java and C#. It is tested with ruby 1.8.4 and the latest soap4r
release.

WSS4R is released unter the GPL.

Please mail bugs, suggestions and patches to
Roland.Schmitt(at)web.de

Best regards,

Roland