New installation: Regexp anchor characters are not allowed


#1

Im trying a new installation with the following problem:

RAILS_ENV=production rake migrate --trace

(in /var/www/rforum-0.2)
rake aborted!
Regexp anchor characters are not allowed in routing requirements:
/^[0-9]+$/
/var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:954:in
assign_route_options' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:949:ineach’
/var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:949:in
assign_route_options' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:1023:inbuild’
/var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:1301:in
add_route' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:1065:inconnect’
/var/www/rforum-0.2/config/routes.rb:3
/var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:1250:in
draw' /var/www/rforum-0.2/config/routes.rb:1 /var/lib/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:489:inload’
/var/lib/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:489:in
load' /var/lib/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:342:innew_constants_in’
/var/lib/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:489:in
load' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:1293:inload_routes!’
/var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:1273:in
load!' /var/lib/gems/1.8/gems/actionpack-2.0.2/lib/action_controller/routing.rb:1288:inreload’
/var/lib/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:293:in
initialize_routing' /var/lib/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:111:inprocess’
/var/lib/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:in send' /var/lib/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:inrun’
/var/www/rforum-0.2/config/environment.rb:10
/var/www/rforum-0.2/Rakefile.rb:9:in require' /var/www/rforum-0.2/Rakefile.rb:9 /usr/lib/ruby/1.8/rake.rb:2149:inload’
/usr/lib/ruby/1.8/rake.rb:2149:in raw_load_rakefile' /usr/lib/ruby/1.8/rake.rb:1897:inload_rakefile’
/usr/lib/ruby/1.8/rake.rb:1948:in standard_exception_handling' /usr/lib/ruby/1.8/rake.rb:1896:inload_rakefile’
/usr/lib/ruby/1.8/rake.rb:1880:in run' /usr/lib/ruby/1.8/rake.rb:1948:instandard_exception_handling’
/usr/lib/ruby/1.8/rake.rb:1878:in `run’
/usr/bin/rake:28

Any clues on why o how to fix this?