New CGRAN upgrades complete!


#1

Hi everyone,

The CGRAN upgrades are finally complete. After our server took a hit
last
week, I figured it was time to upgrade some things while I fixed some
others. CGRAN is now using Trac 0.11.4 and subversion 1.6.0, with some
python and apache module updates in the background. This seems to have
solved our painful internal server error that anyone ever using the wiki
probably saw a million times.

Upgrading to Trac 0.11.4 was a little painful. Our previous theme is
not
supported by 0.11.4, so it’s back to the default look for now, and the
custom account manager I wrote didn’t seamlessly move to 0.11 either, so
I
had to rework that. For anyone interested in the custom account
manager,
it’s in svn/admin/. When a user registers, their account is crippled
(no
editing the wiki or SVN commit access). I receive an e-mail when a user
registers, then I can use the trac to simply authorize them, granting
them
both wiki and SVN access. It’s pretty useful.

If anyone hits any Trac errors please let me know directly so I can work
them out.

Thanks!
George


#2

… and our theme is back! I ported it to 0.11

  • George