Netgear GA311 (Realtek 8169) and USRP 2


#1

The purpose of this email is to ask if anyone (out of the relatively few
USRP2 users) had happened to bump into this card and had similar
difficulty as well as to determine if this is repeatable on other
systems and thus warn others away from the headache I’ve encountered.

I’ve been successful with the Attansic Technology Corp. L1 on an AMD
board I have, but a Netgear GA311 produces odd results. find_usrps
works, but usrp2_siggen fails to identify the daughterboard. I believe
the GA311 is at fault. I was originally on Fedora Core 7 but upgraded to
10 after the initial problems.

Please let me know if you have any experience with this card in general,
or even better, with this card and a USRP2. I’m anxious to resolve the
issue (or return the card).

Thank you in advance.

-Brett


#2

Hi Brett,

I had the same (bad) experience with a RTL-8169 card and USRP2:
approximately 75% of the time “find_usrps” can not detect the USRP2 (the
same for usrp2_fft.py).

I can not confirm the problem (just now I don’t have another card with a
different chipset), but I suspect it is related to the RTL-8169 device.

Best,
Felipe.


#3

OK, it looks like we have some sort of problem with the RTL8169. Can
you guys run the following program in its own window

    while ip -s link show dev eth0 | more -c && sleep 1 ; do : ;done

That will show you stats on the ethernet device. Then run find_usrps
and see how many packets, drops, and errors see what happens. Do the
same thing for when you run usrp2_siggen.

Also, please run ifconfig and send the output.

Thanks,
Matt


#4

Hi Matt,

I followed your instructions and I continued having problems with the
connection: find_usrp2 did not found the USRP2, and surprisingly the “ip
-s link show” command showed 0 packets sent or received. After resetting
the Ethernet connection (removing and inserting the module) I could
detect the USRP2 for a while.

This lead me to discover that the problem was with NetworkManager in my
Ubuntu 8.10 distribution. Disabling the NetworkManager (for example
disabling the nm-applet in the Gnome session) or changing the setup
seems to solve the problem:

* In /etc/network/interfaces set the Gigabit Ethernet as "manual".
      o auto eth2
        iface eth2 inet manual
* In /etc/NetworkManager/nm-system-settings.conf tell networkmanager
  to not touch the configured interfaces in /etc/network/interfaces
      o [ifupdown]
        managed=false

Thank you for your help!
Felipe.


#5

Try doing:

ifconfig eth1 192.168.123.123

Sometimes they need to have a dummy ip address. Also, if you hook up,
but don’t run any programs, do you see packets? Finally, can you try
connecting through a gigabit ethernet hub?

Thanks,
Matt