Netbeans issue

Hi,

Forgive me if this is the wrong place to ask this.

I’m a beginner learning Ruby and I’m trying to create a new Ruby on
Rails
application through Netbeans. I click File -> new project -> Ruby on
Rails
Application … you get the idea.

The problem is on the last dialog. I get an error that the Glassfish Gem
is
not installed and it won’t let me hit the finish button. There’s a
button
that says “Install Glassfish Gem” but running that gives me the
following
error:

JRuby limited openssl loaded. gem install jruby-openssl for full
support.
http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
ERROR: While executing gem … (IOError)
Access is denied

Apparently the wiki.jruby.org site is down, and it cannot pull whatever
it’s
trying to pull off of there. What can I do to workaround? or is there a
proper fix for this?

Thanks,

-Dan

The access denied seems to me to be a permission problem in copying
some of the files… Although I’ve not used NetBeans recently so I’m
not sure how you might sudo that checkbox to see if that helps…

Jay

On Sun, Nov 1, 2009 at 9:41 PM, Daniel R. [email protected]
wrote:

that says “Install Glassfish Gem” but running that gives me the following
trying to pull off of there. What can I do to workaround? or is there a
proper fix for this?

Thanks,

-Dan


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Hi Daniel,

Seems to be an issue with permissions; please check that Gem Home for
the bundled JRuby (i.e.
<nb_install_dir>/ruby2/jruby-x.y.z/lib/ruby/gems/1.8) is writable by the
current user. Did you install NetBeans as the same user you use for
running it? Which version of NB do you use? (I’m asking since recently
another user reported having the same issue with 6.8 Beta, which leads
me to think that there might be some bug in the installer wrt. setting
up permissions).

Erno

PS. There is also http://forums.netbeans.org/ruby-users.html for NB Ruby
users.

Daniel R. wrote:

There’s a button that says “Install Glassfish Gem” but running that
and it cannot pull whatever it’s trying to pull off of there. What can
I do to workaround? or is there a proper fix for this?

Thanks,

-Dan


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Hi,

I think this may be a Window 7 issue. I should have mentioned that’s
what
I’m running. I tried the same steps on OpenSolaris and it worked fine. I
guess I’ll be switching to OpenSolaris for now. I’m not sure how
permissions
work (or don’t work;) in Windows in order to fix it.

Thanks,

-Dan

I have seen this problem in Windows 7.

A simple workaround, is to drag a shortcut for the command prompt to
your
desktop,
right click it, and run it as admin.

You will have the rights to do any gem related activities.
Its a kludge, but its easy to remember.

regards,
Richard.

Hi,

In case somebody comes around here wondering. The installer creates
files and folders which cannot be modified by the current user. You have
to change the permission and grant modification privileges to yourself
in order to remove the error.

Just for information, I had this error while trying to install a gem in
my jruby tree (“gem install” failed with “permission denied”).


Pierre.

Daniel R. wrote:

Hi,

I think this may be a Window 7 issue. I should have mentioned that’s
what
I’m running. I tried the same steps on OpenSolaris and it worked fine. I
guess I’ll be switching to OpenSolaris for now. I’m not sure how
permissions
work (or don’t work;) in Windows in order to fix it.

Thanks,

-Dan

On Thu, Mar 11, 2010 at 3:23 PM, Pierre B. [email protected]
wrote:

Hi,

In case somebody comes around here wondering. The installer creates
files and folders which cannot be modified by the current user. You have
to change the permission and grant modification privileges to yourself
in order to remove the error.

The JRuby installer or the NetBeans installer?

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

On Mon, Mar 15, 2010 at 6:00 PM, Charles Oliver N.
[email protected]wrote:

  • Charlie

The JRuby installer - i.e. system installed JRuby, not the JRuby that
ships
with Netbeans.

I have only seen the issue on windows 7.

On Tue, Mar 16, 2010 at 6:50 PM, Richard C.
[email protected] wrote:

in order to remove the error.

The JRuby installer or the NetBeans installer?

  • Charlie

The JRuby installer - i.e. system installed JRuby, not the JRuby that ships
with Netbeans.
I have only seen the issue on windows 7.

I’m guessing that this isn’t typical for other programs’ installers?
Are we setting permissions too strict?

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Are we setting permissions too strict?

Our installer does a system and not a user install. Apparently
windows 7 is ratcheting down stuff more than previous windows
releases. The obvious solution is to give the option between user and
system install. I don’t have Windows 7 but I am guessing that the user
will have access to all the installed files when it is a user install.
The other obvious solution is to only do a user install, but I
thought we picked system over user for a reason (like servers maybe).

FWIW, for the http://rubyinstaller.org/ we’re using Inno Setup and have
recently moved to using the “lowest” setting as described (and may be
relevant to JRuby)
http://www.jrsoftware.org/ishelp/index.php?topic=setup_privilegesrequired

Their description appears relevant to the JRuby situation.

BTW, we haven’t had any complaints yet with this behavior on Vista+ and
I don’t think we have the file/folder modification issue either; you’ve
got me interested and I’ll check.

Jon

p.s. - I have not upgraded to Windows 7 either, but my testing of the
RubyInstaller’s on Vista from an Admin account using the above setting
puts info under HKCU (user install) and doesn’t pop up the annoying UAC
dialog during install. I also have logic that, for pre-Vista systems,
will do system and user installs appropriate to the user installing.

I don’t know if it will be helpful with your Install4J installer, but
feel free to browse through how we’re doing things at

http://github.com/oneclick/rubyinstaller/blob/fake/resources/installer/util.iss
http://github.com/oneclick/rubyinstaller/blob/fake/resources/installer/fake-rubyinstaller.iss

…and download my FakeRubyInstaller (testing installer) if you want to
check out it’s installation behavior in a variety of situations:

http://groups.google.com/group/rubyinstaller/browse_thread/thread/40311e85b555f463

Maybe this will give some ideas on any needed JRuby installer
updates…


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

hi,

I have win7 at home. Prepare a case and I can try it when I’m at home
later.

kind regards,
marco

Thomas E Enebo schrieb:

wrote:

  • Charlie
    Our installer does a system and not a user install. Apparently
    Any Windows 7 folks in the know on this list?

-Tom


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

On Wed, Mar 17, 2010 at 4:06 PM, Charles Oliver N.
[email protected] wrote:

files and folders which cannot be modified by the current user. You have
I have only seen the issue on windows 7.

I’m guessing that this isn’t typical for other programs’ installers?
Are we setting permissions too strict?

Our installer does a system and not a user install. Apparently
windows 7 is ratcheting down stuff more than previous windows
releases. The obvious solution is to give the option between user and
system install. I don’t have Windows 7 but I am guessing that the user
will have access to all the installed files when it is a user install.
The other obvious solution is to only do a user install, but I
thought we picked system over user for a reason (like servers maybe).

The other option is to make the neccesary directories writable on
install too…ick…

Any Windows 7 folks in the know on this list?

-Tom


blog: http://blog.enebo.com twitter: tom_enebo
mail: [email protected]


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

In case somebody comes around here wondering. The installer creates
files and folders which cannot be modified by the current user. You have
to change the permission and grant modification privileges to yourself
in order to remove the error.

Is the above behavior only for JRuby installs to the default “C:\Program
Files\jruby-1.4.0” dir but not for installs to say “C:\jruby-1.4.0”

If it’s just for installs under “C:\Program Files” the protection
requiring elevation is expected due to Vista’s combined UAC,
virtualization, and protected location behavior.

http://www.symantec.com/connect/articles/folder-virtualization-concepts-windows-vista

http://technet.microsoft.com/en-us/library/cc709628(WS.10).aspx

On my Vista machine, when I installed to “c:\jruby-1.4.0” I was able to
manually delete subdirs and files without the popup. When installed to
“C:\Program Files\jruby-1.4.0” I got a popup when trying to delete files
and folders.

Will be interesting to hear what Marco discovers on his Windows 7 box.

Jon


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

On Fri, Mar 19, 2010 at 4:04 PM, Jon [email protected] wrote:

Is the above behavior only for JRuby installs to the default “C:\Program Files\jruby-1.4.0” dir but not for installs to say “C:\jruby-1.4.0”

FYI, we’re moving away from officially supporting installs to “C:\Program Files” subdirs for multiple reasons…see the last 6 or 7 entries of:

http://groups.google.com/group/rubyinstaller/browse_thread/thread/40311e85b555f463

Yeah, I remember we discussed this wrt to jruby installer and the
agreement was not use “Program Files” location by default. Instead,
we probably should use C:\jruby\1.5 or C:\jruby-1.5 and warn users not
to use paths with spaces.

Thanks,
–Vladimir


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Is the above behavior only for JRuby installs to the default “C:\Program Files\jruby-1.4.0” dir but not for installs to say “C:\jruby-1.4.0”

FYI, we’re moving away from officially supporting installs to
“C:\Program Files” subdirs for multiple reasons…see the last 6 or 7
entries of:

http://groups.google.com/group/rubyinstaller/browse_thread/thread/40311e85b555f463

Jon


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

On Fri, Mar 19, 2010 at 4:57 PM, Vladimir S. [email protected]
wrote:

to use paths with spaces.
One problem I know of is that default Windows security settings don’t
(or at least didn’t used to) allow non-administrators to install
anywhere but Program Files subdirectories. You could argue that
“well, you should just have administrator privileges” but I’ve
actually worked places where they fought tooth and nail to keep devs
from having full admin access. The Program Files hassle is a way of
life on Windows…sucks but true :frowning:

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

On Sat, Mar 20, 2010 at 3:17 AM, Vladimir S. [email protected]
wrote:

Actually, on Windows Vista and Windows 7 this is an opposite for
directories: one can easily create directories on C:, but can’t
create them in “Program Files”. For files, there are a bit different
rules (which involve “virtualization”).

So, for JRuby installer, it is no problem at all to create C:\JRuby
without requiring admin rights, while for installing in Program Files,
it seems, on need admin rights, and for gem installs in that directory
one need admin rights as well, not to mention the path with spaces.

Hence, if I’m not missing something obvious, installing into C:\JRuby
solves all our problems.

Ok, if that’s true, then it’s a great turn of affairs :slight_smile: I have no
objection, if it makes things easier.

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Hi,

On Sat, Mar 20, 2010 at 12:19 AM, Charles Oliver N.
[email protected] wrote:

One problem I know of is that default Windows security settings don’t
(or at least didn’t used to) allow non-administrators to install
anywhere but Program Files subdirectories.

Actually, on Windows Vista and Windows 7 this is an opposite for
directories: one can easily create directories on C:, but can’t
create them in “Program Files”. For files, there are a bit different
rules (which involve “virtualization”).

Here’s what I see on my box:

C:>mkdir directory

C:>touch file

C:>cd “Program Files”

C:\Program Files>mkdir directory
Access is denied.

C:\Program Files>touch file

So, for JRuby installer, it is no problem at all to create C:\JRuby
without requiring admin rights, while for installing in Program Files,
it seems, on need admin rights, and for gem installs in that directory
one need admin rights as well, not to mention the path with spaces.

Hence, if I’m not missing something obvious, installing into C:\JRuby
solves all our problems.

Thanks,
–Vladimir

http://xircles.codehaus.org/manage_email


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Had the same problem with the following config: Win7, NetBeans 6.8,
JRuby shipped with NetBeans.

Solution:
Run your NetBeans as administrator. It will give admin privileges to
JRuby gems installer.

Worked for me.
Hope it will help…

-Philippe

Philippe Rubyeye wrote:

Had the same problem with the following config: Win7, NetBeans 6.8,
JRuby shipped with NetBeans.

Solution:
Run your NetBeans as administrator. It will give admin privileges to
JRuby gems installer.

Worked for me.
Hope it will help…

-Philippe

Thanks Philippe !
Rajiv

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs