Netbeans e RoR

Salve ragazzi

già ho scocciato qualche giorno fa e scoccio di nuovo ora…

come dicevo anche nell’altro post ho netbeans 6.9.1 perchè è l’ultimo
che supporta ruby… ma la versione della gem rails che ha è la 2.3.8
che sta sotto built-in j-ruby 1.5.1 di Netbeans appunto…

il problema è che non mi fa aggionare questa gem… anche se accedo da
amministratore mi aggiorna quasi tutte le gem tranne rails e poche
altre… credo dipenda dal fatto che stia lavorando in j-ruby 1.5.1 che
supporterà fino a una certa versione di gem

ho provato a far girare i progetti sotto jruby 1.6.5 che è esterno o
ruby 1.9.2p290 ma niente da fare… sono riuscito a importarli ma non
riesco a farli funzionare… a me servirebbe jruby dato che dovrei usare
qualcosa di java molto probabilmente

vi ringrazio anticipatamente…

il mio problema in principio è di non lavorare su una versione obsoleta
di rails e poi non so come fare le join con questa versione che ho dato
che OggettoX.joins(:tabella) non mi funziona… dice che l’oggetto non
ha il metodo joins… credo dipenda appunto dalla versione della gem
dato che non funziona neanche .where ma .find_by_sql… ma non è certo
una soluzione accettabile…

Domanda.
Devo proprio usare netbeans?
Il supporto in intellij e’ ottimo.

Andrea

On Dec 21, 2011, at 3:32 PM, Silvio Dell’Oste wrote:

altre… credo dipenda dal fatto che stia lavorando in j-ruby 1.5.1 che
di rails e poi non so come fare le join con questa versione che ho dato
http://lists.ruby-it.org/mailman/listinfo/ml
Andrea C.
[email protected]

come ti ho detto prima nell’altra discussione, a mio parere, per
cominciare
sarebbe meglio usare un editor di testo normale, ma se proprio vuoi
usare
netbeans, la versione beta in procinto di uscire dovrebbe supportare
meglio
rails (mi pare), dacci un occhiata!

Il giorno 21 dicembre 2011 16:25, Silvio Dell’Oste
[email protected]ha scritto:

Andrea C. wrote in post #1037693:

Domanda.
Devo proprio usare netbeans?
Il supporto in intellij e’ ottimo.

Andrea

On Dec 21, 2011, at 3:32 PM, Silvio Dell’Oste wrote:

altre… credo dipenda dal fatto che stia lavorando in j-ruby 1.5.1 che
di rails e poi non so come fare le join con questa versione che ho dato
http://lists.ruby-it.org/mailman/listinfo/ml
Andrea C.
[email protected]

beh… non è del tutto obbligatorio… in realtà già ho scritto qualcosa
e spero di non metterci troppo a capire eventualmente questo IDE e
passare il progetto e le varie configurazioni…

se possibile continure con netbeans ma con una versione nuova di rails
sarebbe fantastico… altrimenti mi adeguo…

Luca B. wrote in post #1037700:

come ti ho detto prima nell’altra discussione, a mio parere, per
cominciare
sarebbe meglio usare un editor di testo normale, ma se proprio vuoi
usare
netbeans, la versione beta in procinto di uscire dovrebbe supportare
meglio
rails (mi pare), dacci un occhiata!

Il giorno 21 dicembre 2011 16:25, Silvio Dell’Oste
[email protected]ha scritto:

Grazie Luca :slight_smile:

sto provando anche Aptana Studio per Eclipse ma dopo aver scritto già un
pò di cose su Netbeans e capito varie cosine preferirei non partire da
capo…

comunque la parte da linea di comando l’ho già sperimentata… anche se
come editor usavo il blocco note XD

Anche Netbeans 7 (io uso la 7.0.1) supporta Rails, non ufficialmente ma
puoi tranquillamente installare i plugin necessari cercandoli tra quelli
disponibili (Men Tools => Plugins).
Se fossi in te non userei il Ruby / jRuby in bundle con Netbeans, ma
installerei la versione di Ruby / jRuby che ti serve sul sistema e
lancerei
il server da terminale.

Il giorno 21 dicembre 2011 16:49, Luca B. [email protected] ha
scritto:

Alessandro V. wrote in post #1037721:

Anche Netbeans 7 (io uso la 7.0.1) supporta Rails, non ufficialmente ma
puoi tranquillamente installare i plugin necessari cercandoli tra quelli
disponibili (Men Tools => Plugins).
Se fossi in te non userei il Ruby / jRuby in bundle con Netbeans, ma
installerei la versione di Ruby / jRuby che ti serve sul sistema e
lancerei
il server da terminale.

Il giorno 21 dicembre 2011 16:49, Luca B. [email protected] ha
scritto:

questo non lo sapevo… se possibile potresti darmi qualche dettaglio in
più?

in pratica mi dici che nelle nuove versioni di netbeans posso prendere
dei plug-in… anche se non credo sia una cosa fondamentale per me
adesso…

la cosa che mi interessa è la seconda… ossia usare una versione
esterna di Ruby o JRuby ma… come? io le ho messe ma non mi funziona
nulla…

cosa intendi per lanciare il server da terminale? che non posso usare la
rails console interna?

perdonami se non ho capito dato che io quando lancio il run uso
glassfish ma comunque su un browser esterno… meglio non dire altro se
no potrei sparare fesserie… se si può mettere una nuova versione di
rails sotto netbeans mi renderesti molto contento :slight_smile: poi è da vedere
quale è il dazio da pagare… spero che ci sia comunque
l’autocompletamento e la generazione dello scheletro :slight_smile:

grazie

io uso il terminale + *sublime text 2(mi supporta Sass, Haml,
eccetera…
)

  • oppure *gedit

*cmq pieno di semplici rich editor, il blocco note proprio triste,
concordo con te :stuck_out_tongue:

Il giorno 21 dicembre 2011 16:42, Silvio Dell’Oste
[email protected]ha scritto:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs