Net/toc, disconnects, and aol

Hello all.

I’ve been using the Net::TOC library
(http://rubyforge.org/projects/net-toc/) for an AIM bot. It was working
pretty well for a while. Every few days, however, the bot would get
disconnected. There would be no exception thrown, the ruby process
would still be alive, and netstat would still show the connection as
established. It wasn’t a huge deal, as the bot isn’t mission critical,
and I was always around to restart it.

But as of a couple of weeks ago, the bot has been unable to stay
connected for any longer than 2 or 3 minutes. And as I discovered,
nothing I tried could get anything to stay connected with net/toc. I’ve
pared it down to only sending a simple response to an IM, I’ve tried
different machines, Windows and Linux, different screennames, I’ve
pared it down further to just logging on and doing nothing. None of it
helped. Within three minutes or so, it gets disconnected with no
exception, the tread still alive, and netstat showing an open
connection.

Has anyone else out there using net/toc run into the same issue? I feel
like I’ve narrowed it down to… well, I think I’ve narrowed it down to
not my fault. (I’m also wondering if anyone uses net/toc besides me.)
Thanks.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs