Need suggestion about jruby rails and websphere

I need to develop a bunch of web apps that will run in a very legacy
environment, websphere 8 under zlinux.
Being a rails addict i would like to use this framework, and
seems to be the only way to do it.

This is all new for me, and I cannot even get the simplest rails app to
compiled with warbler, because i get
a “stack level too deep” error everytime i run warbler.
I use ubuntu 12.04 for development rvm last version, jruby 1.7.4 rails
3.2.13 and warbler 1.3.8,
and tried on different pc getting the same problem.

I already posted on github issues for warbler, and saw that other people
are having the same problem.

I’m getting the impression that the environment i’m targeting is too far
from jruby at this moment, and looking at the github statistics for
it seems even more distant.

Is there someone who can suggest me if this is a road that can be
(i.e. this is a single problem that can be solved and then things ca go
smoothly) or if I better switch to native java stuff like

Best regards


Post your simple rails app with the list of commands needed to reproduce
the failure to github and I’ll take a look. I develop a rails app which
gets deployed to websphere on linux or windows and things seem to work

Trying to re-create the problem I found where the problem is:

  • rails new testapp --database mysql
  • bundle install
  • modified database.yml to add the correct username and password
  • rake db:create
  • rails g scaffold person name:string age:integer
  • rake db:migrate
  • then, running webrick locally the app (of course…) works.
  • warble pluginize <== the culprit
    and lib/tasks/warbler/warbler.rake is created

Now if i run “warble -T” or “warble config” i get the “stack too deep”

Avoiding the creation of warble rake taks allows building the war file


2013/6/5 Alex T. [email protected]

Can you add those details to this ticket?

Hopefully we can get that fixed. Thanks!