Need installation help

I’ve installed RoR on Fedora Core 6, following closely the
instructions on
http://www.digitalmediaminute.com/howto/fc4rails/#installROR

When I try to launch RoR test app, I get an error:
Cannot find gem for Rails ~>1.2.3.0:
Install the missing gem with ‘gem install -v=1.2.3 rails’, or
change environment.rb to define RAILS_GEM_VERSION with your
desired version.

I get this either by “service lighttpd restart” or by simply
# ruby public/dispatch.fcgi

My config/environment.rb has
RAILS_GEM_VERSION = ‘1.2.3’ unless defined? RAILS_GEM_VERSION

I tried to run with
RAILS_GEM_VERSION=1.2.3.0 ruby public/dispatch.fcgi
but am getting the same error.

The rails install ran just fine:

gem install rails --include-dependencies

Attempting local installation of ‘rails’
Local gem file not found: rails*.gem
Attempting remote installation of ‘rails’
Updating Gem source index for: http://gems.rubyforge.org
Successfully installed rails-1.2.3
Successfully installed rake-0.7.3
Successfully installed activesupport-1.4.2
Successfully installed activerecord-1.15.3
Successfully installed actionpack-1.13.3
Successfully installed actionmailer-1.3.3
Successfully installed actionwebservice-1.2.3
Installing RDoc documentation for rake-0.7.3…
Installing RDoc documentation for activesupport-1.4.2…
Installing RDoc documentation for activerecord-1.15.3…
Installing RDoc documentation for actionpack-1.13.3…
Installing RDoc documentation for actionmailer-1.3.3…
Installing RDoc documentation for actionwebservice-1.2.3…
rubygems-0.9.1-1.fc6
I have installed everything possible using yum, including rubygems
I’ve installed RoR on Fedora Core 6, following closely the
instructions on
http://www.digitalmediaminute.com/howto/fc4rails/#installROR

When I try to launch RoR test app, I get an error:
Cannot find gem for Rails ~>1.2.3.0:
Install the missing gem with ‘gem install -v=1.2.3 rails’, or
change environment.rb to define RAILS_GEM_VERSION with your
desired version.

I get this either by “service lighttpd restart” or by simply
# ruby public/dispatch.fcgi

My config/environment.rb has
RAILS_GEM_VERSION = ‘1.2.3’ unless defined? RAILS_GEM_VERSION

I tried to run with
RAILS_GEM_VERSION=1.2.3.0 ruby public/dispatch.fcgi
but am getting the same error.

The rails install ran just fine:

gem install rails --include-dependencies

Attempting local installation of ‘rails’
Local gem file not found: rails*.gem
Attempting remote installation of ‘rails’
Updating Gem source index for: http://gems.rubyforge.org
Successfully installed rails-1.2.3
Successfully installed rake-0.7.3
Successfully installed activesupport-1.4.2
Successfully installed activerecord-1.15.3
Successfully installed actionpack-1.13.3
Successfully installed actionmailer-1.3.3
Successfully installed actionwebservice-1.2.3
Installing RDoc documentation for rake-0.7.3…
Installing RDoc documentation for activesupport-1.4.2…
Installing RDoc documentation for activerecord-1.15.3…
Installing RDoc documentation for actionpack-1.13.3…
Installing RDoc documentation for actionmailer-1.3.3…
Installing RDoc documentation for actionwebservice-1.2.3…

I have installed everything possible using yum, including
rubygems-0.9.1-1.fc6

I’d appreciate any ideas.
Dan

maybe Rails test app depends on 1.2.3.0.
Try to create an app:
rails testapp
cd testapp/ && ./script/server

then start your browser and point it to http://0.0.0.0:3000

I’ve tried to gem install -v 1.2.2 rails
and it started working.

I guess there’s a bug in gem 1.2.3

Thanks,
Dan

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs