Need help with SQLite3

I am trying to install SQLite3

I put the required Windows32 files into my path. I installed the gem
sqlite3-ruby successfully … but something is wrong!

I tested the installation with:

require ‘rubygems’
require ‘sqlite3’
puts “It’s all okay!” if defined?(SQLite3::Database)

On out put I get nothing … if all was setup ok i should get out of:

It’s all okay!

Any idea what could be causing the issue?

Joshua C. wrote:

I am trying to install SQLite3

I put the required Windows32 files into my path. I installed the gem
sqlite3-ruby successfully … but something is wrong!

I tested the installation with:

require ‘rubygems’
require ‘sqlite3’
puts “It’s all okay!” if defined?(SQLite3::Database)

On out put I get nothing … if all was setup ok i should get out of:

It’s all okay!

Any idea what could be causing the issue?

What directory was your prompt pointing at? What is the output when you
type:

…some/path> sqlite3

when I type $ sqlite3

No matter the directory since it is in my path

I get the output

SQLite version 3.6.13
Enter “.help” for instructions
Enter SQL statements terminated with “;”
sqlite>

But, it seems my Ruby is not connecting to SQLite3. For instance, that
test
file I setup should have gave the prompted text if it returned TRUE, but
it
seems to have returned FALSE

So, any code I write will not interface with the database :-\

On May 4, 3:03 am, Joshua C. [email protected] wrote:

Enter SQL statements terminated with “;”

I am trying to install SQLite3
On out put I get nothing … if all was setup ok i should get out of:

Posted viahttp://www.ruby-forum.com/.

Do you have sqlite3.dll in your path too?

Regards,
Bosko

Bosko I. wrote:

On May 4, 3:03�am, Joshua C. [email protected] wrote:

Enter SQL statements terminated with “;”

I am trying to install SQLite3
On out put I get nothing … if all was setup ok i should get out of:

Posted viahttp://www.ruby-forum.com/.

Do you have sqlite3.dll in your path too?

Regards,
Bosko

This has probably nothing to do with sqlite3.dll.

I guess something is wrong with sqlite3 gem. Try to uninstall it and
install it again.

by
TheR

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs