Need help installing Gems package (Newbie question)

When I run the rake command (rake db:migrate) and run it, I get this
error message. (I’m currently running Rails 2.0.2)

Missing the Rails 2.0.2 gem. Please gem install -v=2.0.2 rails,
update your RAILS_GEM_VERSION setting in config/environment.rb for the
Rails version you do have installed, or comment out RAILS_GEM_VERSION
to use the latest version installed.

What do I need to do, and how do I do it? I’m fairly new to command-
line commands, so please be detailed.

Thank you.

Hi,

What operating system are you using?

either way, you ought to be able to go into a command line and type

rails -v

to get the version back… let us know what this tells you. It seems
to be complaining that you don’t actually have the version you think
you have installed.

Julian

Learn Ruby on Rails! Check out the FREE VIDS (for a limited time)
VIDEO #4 parts a and b now available!
http://sensei.zenunit.com/

I’m running Mac OS 10.5.2. Leopard and Rails 2.0.2.

I thought that these were the most current versions so I was surprised
that I had this problem with GEM.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs