Need a helping hand setting up ssl server on local box

Here is my setup (detailed): https://gist.github.com/719862

I can access the port 80 server but not port 443.

I get Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error. in chrome.

Another strange issue is the log files for either the port 80 or 443
server don’t appear where I told them to go in the config. (There are
error and access logs in the homebrew nginx location but nothing of
value in there.

Struggling right now to figure out what I’m doing wrong…

I’d appreciate any help…

Regards,

Saimon

Hello!

On Mon, Nov 29, 2010 at 12:45:50PM +0100, Saimon M. wrote:

Struggling right now to figure out what I’m doing wrong…

I’d appreciate any help…

Try looking into global error log, it should be in
/usr/local/Cellar/nginx/0.8.53/logs/error.log with your setup.

Maxim D.

Hi Maxim,

I did and there’s nothing (new) in there… :frowning:

On Mon, Nov 29, 2010 at 1:25 PM, Maxim D. [email protected]
wrote:

Another strange issue is the log files for either the port 80 or 443

Maxim D.


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Saimon M.
Freelance Web D.
(Available for hire - For details visit http://saimonmoore.net)

Skype: saimonmoore
Yahoo IM: saimonmoore
Google IM: saimonmoore

Can some please take a quick look at my nginx config to see if there’s
anything obviously wrong I may be missing? I’ve been trying different
variations of the same thing but I’m still not able to get ssl working
on my local osx box.

On Mon, Nov 29, 2010 at 2:19 PM, Saimon M. [email protected]
wrote:

http://nginx.org/mailman/listinfo/nginx
Yahoo IM: saimonmoore
Google IM: saimonmoore


Saimon M.
Freelance Web D.
(Available for hire - For details visit http://saimonmoore.net)

Skype: saimonmoore
Yahoo IM: saimonmoore
Google IM: saimonmoore

Hello!

On Mon, Nov 29, 2010 at 02:19:50PM +0100, Saimon M. wrote:

Hi Maxim,

I did and there’s nothing (new) in there… :frowning:

So the most likely reason is that you forgot to reload nginx
config. It should complain there why it wasn’t able to parse your
config and/or open configured listening sockets. Even if you were
smart enough to redirect stderr to something like /dev/null.

Another possible reason is that you have wrong binary running and
it tries to read configs from another place.

Full restart should resolve both mentioned issues.

Maxim D.

p.s. Please do not top-post. Thank you.

On Mon, Nov 29, 2010 at 4:37 PM, Maxim D. [email protected]
wrote:

config and/or open configured listening sockets. Even if you were
smart enough to redirect stderr to something like /dev/null.

As expected my bad. Sorry for the noise.
You were on the right track. I had two configs setup in
sites-available. The one I was interested in wasn’t symlinked in
sites-enabled. duh.

Thanks again…


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Saimon M.
Freelance Web D.
(Available for hire - For details visit http://saimonmoore.net)

Skype: saimonmoore
Yahoo IM: saimonmoore
Google IM: saimonmoore