Ncurses-ruby installation in cygwin

hi-

i’m trying to install ncurses-ruby on cygwin on windows. if i open up a
cygwin terminal and go to the decompressed ncurses-ruby directory and
type in “ruby extconf.rb” i get this error:

checking for unistd.h… no
checking for /usr/include/ncurses.h… no
checking for ncurses/curses.h… no
checking for /usr/include/curses.h… no
./extconf.rb:35: ncurses header file not found (RuntimeError)

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details.
You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/bin/ruby

if i do ruby extconf.rb --srcdir=/usr/include i get the same error. i
did install the ncurses-devel package through cygwin and the files do
exist in C:\cygwin\usr\include\ncurses. curses.h is a file there. it
seems like the ruby configure script doesn’t know to look in that
directory. but supplying srcdir in the command line doesn’t help. also,
unistd.h is in that same directory: /usr/include. i’m at a loss. any
ideas? thanks!

my problem was that i didn’t include the gcc and make packages when
installing cygwin. now it works!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs