Naming suggestion required

Hello,

I am writing a program that will fetch me lyrics from any one of a
possible
number of sites. For this I have the following setup:

class AbstractLyricFooBarSomething(this is the name suggestion I
require)
def init
@artist=""
@title=""
@lyric=""
end
attr_reader :lyric,:artist,:title
end

class MetroLyrics < FooBarSomething
def init url
#do magic
end
end

and so on. There’ll be a factory that takes in the search queries and
returns an appropriate object(s)

What should I call FooBarSomething? I thought of the following and none
of
them seemed to fit the paradigm.

Lyrics
LyricEngine
LyricsParser
Lyricalizer

Thank you,

Jayanth

Umm, sorry, read init as initialize, too much Python happening on the
side
:wink:

Jayanth

On Fri, Jun 12, 2009 at 12:48 PM, Srijayanth S.

On Jun 12, 3:18 am, Srijayanth S. [email protected] wrote:

end
returns an appropriate object(s)

What should I call FooBarSomething? I thought of the following and none of
them seemed to fit the paradigm.

Lyrics
LyricEngine
LyricsParser
Lyricalizer

Generally speaking go with just “Lyrics”. But also have you wrapped
everything in a name space? Eg.

module LyricsLicker

class Lyrics
  ...
end

class MetroLyrics < Lyrics
  ...
end

end

T.

class MetroLyrics < Lyrics

end

end

T.

Thanks for the suggestion. I will wrap it up in a namespace.

I actually dig LyricsLicker. Pretty cool.

Thanks,

Jayanth