N210 FPGA image not compatible with the host uhd code build?

Hello community,

There seems to be software compatibility issue between the host (ubuntu
12.04) uhd build and USRP N210 FPGA image. The Runtime errors are
captured
as:


$ uhd_usrp_probe
linux; GNU C++ version 4.6.3; Boost_104601;
UHD_003.004.003-224-gc2e197c0

– Opening a USRP2/N-Series device…
Error: RuntimeError:
Please update the firmware and FPGA images for your device.
See the application notes for USRP2/N-Series for instructions.
Expected FPGA compatibility number 10, but got 9:
The FPGA build is not compatible with the host code build.
Please run:

sudo “/usr/local/share/uhd/utils/uhd_images_downloader.py”
“/usr/local/share/uhd/utils/usrp_n2xx_net_burner.py”
–fpga="/usr/local/share/uhd/images/usrp_n210_r4_fpga.bin"
–fw="/usr/local/share/uhd/images/usrp_n210_fw.bin"
–addr=“192.168.10.2”


So I did perform the above command shown in the output message. After
downloading the image, the system claims that the FPGA write image was
successful. But when I tried the “uhd_usrp_probe” command again, it
still
has the same error message, as if the updating did nothing to change the
situation.

I did notice that when downloading the image, it was from:

Downloading images from:
http://files.ettus.com/binaries/master_images/archive/uhd-images_003.004.003-205-g4896bf78.zip

But the message from the probe command returns the uhd image version as
follows:

$ uhd_usrp_probe
linux; GNU C++ version 4.6.3; Boost_104601;
UHD_003.004.003-224-gc2e197c0

Is it possible that the downloaded fpga images is outdated, and a
correct
version that matches the label 224 would work? Where is the correct FPGA
image to download?

Thanks,

LD Zhang

On 09/19/2012 05:29 PM, LD Zhang wrote:

– Opening a USRP2/N-Series device…
–fw="/usr/local/share/uhd/images/usrp_n210_fw.bin"
–addr=“192.168.10.2”

Hmm, not sure. Make sure you are

  1. There are two commands there. The downloader and the burner. Make
    sure both are executed.

  2. You will need to power cycle the USRP after the burn

If that is failing, let me know but… it looks like you have installed
the master branch. So the compatible images can be manually grabbed from
here: http://files.ettus.com/binaries/master_images/

-josh

Yes it was my fault. Power cycle did the trick.

LD

Hmm, not sure. Make sure you are

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs