N210 and GRC

Hello,

I have recently started to work on the USRP N210 and its the first time
I am working on the USRP and GNU radio. I have managed to install the
GNU radio and uhd successfully on my system. The firmware and the FPGA
image have been loaded successfully (as indicated by the leds). The
device also pings successfully and also able to obtain outputs for
uhd_find_devices and uhd_usrp_probe.

Initially I tried using the usrp2_fft.py but was unsuccessful. Thus
later understood from the forum that the UHD does not support the python
scripts and that we have to use the GRC.

Now I tried a basic connection in a GRC, namely from a UHD USRP source
to a FFT sink but I got an error mentioning

"
Warning:
error in pthread_setschedparam
Failed to set thread priority 0.5 (realtime):
Performance may be negatively affected.
See the general application notes
UHD source block got error code 0x1
gr_block_executor: source <gr_block gr uhd usrp source (1)> produced no
output. We’re marking it DONE

"

Could anyone please help me if I am going wrong somewhere. Could you
please provide me some direction as to how it can be rectified

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs