Mysql::Error: Lost connection to MySQL server during query: SELECT * FROM sessions WHERE (session_i

Hi
i keep on getting this error when i try to GET one of the page in my
website. any idea where went wrong. was it something wrong with the
server?
Mysql::Error: Lost connection to MySQL server during query: SELECT *
FROM sessions WHERE (session_id = ‘55f84af9071afac179e25506d37fab42’)
LIMIT 1

Here’s the complete error message
Processing AdminController#list (for 127.0.0.1 at 2008-01-15 00:14:59)
[GET]
Session ID: 55f84af9071afac179e25506d37fab42
Parameters: {“action”=>“list”, “controller”=>“admin”}
^[[4;35;1mMembership Load (0.002293)^[[0m ^[[0mSELECT * FROM
memberships ^[[0m
^[[4;36;1mMembership Columns (0.006878)^[[0m ^[[0;1mSHOW FIELDS
FROM memberships^[[0m
^[[4;35;1mUser Columns (0.032467)^[[0m ^[[0mSHOW FIELDS FROM
users^[[0m
^[[4;36;1mUser Load (0.009823)^[[0m ^[[0;1mSELECT * FROM users
WHERE (users.id = 1) LIMIT 1^[[0m
^[[4;35;1mUser Load (0.005218)^[[0m ^[[0mSELECT * FROM users WHERE
(users.id = 1) LIMIT 1^[[0m
^[[4;36;1mCategory Load (0.002756)^[[0m ^[[0;1mSELECT * FROM
categories ^[[0m
^[[4;35;1mCategory Columns (0.009436)^[[0m ^[[0mSHOW FIELDS FROM
categories^[[0m
^[[4;36;1mBrand Load (0.002521)^[[0m ^[[0;1mSELECT * FROM brands
^[[0m
^[[4;35;1mBrand Columns (0.010849)^[[0m ^[[0mSHOW FIELDS FROM
brands^[[0m
^[[4;36;1mProduct Columns (0.009531)^[[0m ^[[0;1mSHOW FIELDS FROM
products^[[0m
^[[4;35;1mSQL (0.002523)^[[0m ^[[0mSELECT count(*) AS count_all
FROM products ^[[0m
^[[4;36;1mProduct Load (0.003852)^[[0m ^[[0;1mSELECT * FROM
products LIMIT 0, 20^[[0m
Rendering within layouts/admin
Rendering admin/list
Rendered admin/_left_sidebar (0.00582)
^[[4;35;1mBrand Load (0.002364)^[[0m ^[[0mSELECT * FROM brands
WHERE (brands.id = 11) ^[[0m
^[[4;36;1mCategory Load (0.002333)^[[0m ^[[0;1mSELECT * FROM
categories WHERE (categories.id = 2) ^[[0m
^[[4;35;1mCategory Load (0.002326)^[[0m ^[[0mSELECT * FROM
categories WHERE (categories.id = 1) ^[[0m
^[[4;36;1mTag Columns (0.006939)^[[0m ^[[0;1mSHOW FIELDS FROM
tags^[[0m
^[[4;35;1mTag Load (0.004283)^[[0m ^[[0mSELECT * FROM tags WHERE
(tags.id = 26) ^[[0m
Rendered /admin/_tabs (0.00646)
Completed in 0.38937 (2 reqs/sec) | Rendering: 0.06513 (16%) | DB:
0.11639 (29%) | 200 OK [http://localhost/admin/list]
Mysql::Error: Lost connection to MySQL server during query: SELECT *
FROM sessions WHERE (session_id = ‘55f84af9071afac179e25506d37fab42’)
LIMIT 1
./script/…/config/…/vendor/rails/activerecord/lib/active_record/
connection_adapters/abstract_adapter.rb:128:in log'^M ./script/../config/../vendor/rails/activerecord/lib/active_record/ connection_adapters/mysql_adapter.rb:243:inexecute’^M
./script/…/config/…/vendor/rails/activerecord/lib/active_record/
connection_adapters/mysql_adapter.rb:399:in select' ./script/../config/../vendor/rails/activerecord/lib/active_record/ connection_adapters/abstract/database_statements.rb:7:inselect_all’^M
./script/…/config/…/vendor/rails/activerecord/lib/active_record/
base.rb:427:in find_by_sql'^M ./script/../config/../vendor/rails/activerecord/lib/active_record/ base.rb:997:infind_every’^M
./script/…/config/…/vendor/rails/activerecord/lib/active_record/
base.rb:991:in find_initial'^M ./script/../config/../vendor/rails/activerecord/lib/active_record/ base.rb:417:infind’^M
./script/…/config/…/vendor/rails/actionpack/lib/action_controller/
session/active_record_store.rb:115:in find_by_session_id'^M ./script/../config/../vendor/rails/actionpack/lib/action_controller/ session/active_record_store.rb:288:ininitialize’^M
./script/…/config/…/vendor/rails/activerecord/lib/active_record/
base.rb:867:in silence'^M ./script/../config/../vendor/rails/actionpack/lib/action_controller/ session/active_record_store.rb:288:ininitialize’^M
/opt/local/lib/ruby/1.8/cgi/session.rb:273:in new'^M /opt/local/lib/ruby/1.8/cgi/session.rb:273:ininitialize_without_dynamic_session_expiration’^M
./script/…/config/…/vendor/plugins/dynamic_session_exp/lib/
dynamic_session_expiry.rb:34:in initialize'^M ./script/../config/../vendor/rails/actionpack/lib/action_controller/ cgi_process.rb:123:innew’^M
./script/…/config/…/vendor/rails/actionpack/lib/action_controller/
cgi_process.rb:123:in session'^M ./script/../config/../vendor/rails/actionpack/lib/action_controller/ cgi_process.rb:155:instale_session_check!’^M
./script/…/config/…/vendor/rails/actionpack/lib/action_controller/
cgi_process.rb:110:in session'^M ./script/../config/../vendor/rails/actionpack/lib/action_controller/ base.rb:1052:inassign_shortcuts_without_flash’^M
./script/…/config/…/vendor/rails/actionpack/lib/action_controller/
flash.rb:140:in assign_shortcuts'^M ./script/../config/../vendor/rails/actionpack/lib/action_controller/ base.rb:424:inprocess_without_filters’^M
./script/…/config/…/vendor/rails/actionpack/lib/action_controller/
filters.rb:624:in process_without_session_management_support'^M ./script/../config/../vendor/rails/actionpack/lib/action_controller/ session_management.rb:114:inprocess’^M
./script/…/config/…/vendor/rails/actionpack/lib/action_controller/
base.rb:330:in process'^M ./script/../config/../vendor/rails/railties/lib/dispatcher.rb:41:indispatch’^M
./script/…/config/…/vendor/rails/railties/lib/webrick_server.rb:
113:in handle_dispatch'^M ./script/../config/../vendor/rails/railties/lib/webrick_server.rb: 79:inservice’^M
/opt/local/lib/ruby/1.8/webrick/httpserver.rb:104:in service'^M /opt/local/lib/ruby/1.8/webrick/httpserver.rb:65:inrun’^M
/opt/local/lib/ruby/1.8/webrick/server.rb:173:in start_thread'^M /opt/local/lib/ruby/1.8/webrick/server.rb:162:instart’^M/opt/local/
lib/ruby/1.8/webrick/server.rb:162:in start_thread'^M /opt/local/lib/ruby/1.8/webrick/server.rb:95:instart’^M
/opt/local/lib/ruby/1.8/webrick/server.rb:92:in each'^M /opt/local/lib/ruby/1.8/webrick/server.rb:92:instart’^M
/opt/local/lib/ruby/1.8/webrick/server.rb:23:in start'^M /opt/local/lib/ruby/1.8/webrick/server.rb:82:instart’^M
./script/…/config/…/vendor/rails/railties/lib/webrick_server.rb:
63:in dispatch'^M ./script/../config/../vendor/rails/railties/lib/commands/servers/ webrick.rb:59^M /opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’^M
/opt/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require'^M ./script/../config/../vendor/rails/activesupport/lib/active_support/ dependencies.rb:498:inrequire’^M
./script/…/config/…/vendor/rails/activesupport/lib/active_support/
dependencies.rb:345:in new_constants_in'^M ./script/../config/../vendor/rails/activesupport/lib/active_support/ dependencies.rb:498:inrequire’^M
./script/…/config/…/vendor/rails/railties/lib/commands/server.rb:
39^M
script/server:3:in `require’^M
script/server:3

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs