Mysql-5.0.41 and mysql native gem

Has anyone else had problems with the mysql native gem when using
MySQL 5.0.41. It appears that this version of MySQL has moved some
depended library files. I rolled back to MySQL 5.0.37 and all seems
to be working now. But, just wanted to know if anyone else has
experienced this issue.

Hi Robert,

Has anyone else had problems with the mysql native gem when using
MySQL 5.0.41. It appears that this version of MySQL has moved some
depended library files. I rolled back to MySQL 5.0.37 and all seems
to be working now. But, just wanted to know if anyone else has
experienced this issue.

As the maintainer of the Windows native driver at
http://www.vandomburg.net, I’ve heard similar reports. I haven’t gotten
to compiling a newer version yet but will do so in the coming week.


Roderick van Domburg
Nedforce http://www.nedforce.nl

I’m seeing an extra, non-existent, directory called for in the path
to this library:
libmysqlclient.15.dylib

The error was encountered while doing a script/generate:

dyld: NSLinkModule() error
dyld: Library not loaded: /usr/local/mysql/lib/mysql/libmysqlclient.
15.dylib
Referenced from: /usr/local/lib/ruby/gems/1.8/gems/mysql-2.7/lib/
mysql.bundle
Reason: image not found
Trace/BPT trap

The actual location of the library is:

/usr/local/mysql/lib/libmysqlclient.15.dylib

It would be a little unnecessary to have …/mysql/lib/mysql/… I
would think.

For now I’m going to try a symlink…

Jim

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs