My RMagick sucks under windowsXP

Hi,I plan to use rmagick for my rails app,however it can not work
normally under windowsXP platform:
I have installed ruby1.8.5,and then rmagick-1.14.1 and
ImageMagick-6.3.0-7-Q8-windows-dll,which can be got from the url:
http://rubyforge.org/frs/download.php/15132/RMagick-1.14.1_IM-6.3.0-7-Q8.zip
after my installation,and when i run a rmagick test under
C:\ruby\lib\ruby\gems\1.8\gems\rmagick-1.13.0-win32\doc\ex
I use the following instruction:
ruby texturefill.rb
and I have got the following errors:

C:\ruby\lib\ruby\gems\1.8\gems\rmagick-1.13.0-win32\doc\ex>ruby
texturefill.rb texturefill.rb:7:in initialize': undefined methodcur_image’ for #<Magick::Ima
ge:0x2e7a3cc> (NoMethodError)
from texturefill.rb:7:in `new’
from texturefill.rb:7
texturefill.rb:7: [BUG] Segmentation fault
ruby 1.8.5 (2006-12-25) [i386-mswin32]

This application has requested the Runtime to terminate it in an unusual
way.
Please contact the application’s support team for more information.

However,If I use ruby1.8.4 and rmagick-1.13.0 which can be got from
http://rubyforge.org/frs/download.php/12421/rmagick-1.13.0-IM-6.2.9-0-win32.zip
All works well.

It seems that the latest rmagick package release can not work well with
ruby1.8.5 under windows platform.Can anyone here help me with how to
resolve this? Tks

Fredric

If I uninstalled my ruby1.8.5(version: ruby185-22Final) and reinstalled
ruby1.8.5-24, everything is ok.
A strange problem

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs