My rails app does not work

Hi,

my app is not work. Can you help me?

cannot load such file – bundler

Application log:

[ pid=11873 thr=69923239138300 file=utils.rb:176 time=2014-01-27
20:00:04.706 ]: *** Exception LoadError in
PhusionPassenger::Rack::ApplicationSpawner (cannot load such file –
bundler) (process 11873, thread #Thread:0x007f308ba927f8):
from
/usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in
require' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/utils.rb:325:in
prepare_app_process' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/rack/application_spawner.rb:156:inblock in initialize_server’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/utils.rb:563:in
report_app_init_status' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/rack/application_spawner.rb:154:ininitialize_server’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/abstract_server.rb:204:in
start_synchronously' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/abstract_server.rb:180:instart’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/rack/application_spawner.rb:129:in
start' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/spawn_manager.rb:253:inblock (2 levels) in spawn_rack_application’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/abstract_server_collection.rb:132:in
lookup_or_add' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/spawn_manager.rb:246:inblock in spawn_rack_application’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/abstract_server_collection.rb:82:in
block in synchronize' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/abstract_server_collection.rb:79:insynchronize’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/abstract_server_collection.rb:79:in
synchronize' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/spawn_manager.rb:244:inspawn_rack_application’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/spawn_manager.rb:137:in
spawn_application' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/spawn_manager.rb:275:inhandle_spawn_application’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/abstract_server.rb:357:in
server_main_loop' from /usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/abstract_server.rb:206:instart_synchronously’
from
/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/helper-scripts/passenger-spawn-server:99:in
`’

The app link is:
http://www.displayblock.com.br/

ruby -v

ruby 2.1.0p0 (2013-12-25 revision 44422) [x86_64-linux]

rails -v

Rails 4.0.1

bundle -v

Bundler version 1.5.2

On Monday, January 27, 2014 8:16:06 PM UTC, Marcus Vinicius wrote:

`require’
from

/usr/local/lib/ruby/gems/1.8/gems/passenger-3.0.19/lib/phusion_passenger/utils.rb:325:in

`prepare_app_process’

This bit of your stack trace is concerning - it seems to indicate that
your
app is running in an environment that is part ruby 1.8, part ruby 2.1.
Did
you reinstall the passenger gem and the corresponding apache/nginx
module
after you installed 2.1.0? Is the snippet in your apache/nginx config
pointing at the correct ruby install?

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs