My app broke this morning on with this error

Like I said, my app suddenly stoped working in the last few minutes.
I’m on dreamhost but I’m running rdge rails locked in on the 1.1
release.

Stale NFS file handle - …/config/…/log/production.log
/usr/lib/ruby/1.8/logger.rb:520:in write' /usr/lib/ruby/1.8/logger.rb:520:inwrite’
/usr/lib/ruby/1.8/logger.rb:318:in add' /usr/lib/ruby/1.8/logger.rb:372:ininfo’
…/config/…/vendor/rails/actionpack/lib/action_controller/base.rb:900:in
log_processing' ../config/../vendor/rails/actionpack/lib/action_controller/base.rb:378:inprocess_without_filters’
…/config/…/vendor/rails/actionpack/lib/action_controller/filters.rb:364:in
process_without_session_management_support' ../config/../vendor/rails/actionpack/lib/action_controller/session_management.rb:117:inprocess’
…/config/…/vendor/rails/railties/lib/dispatcher.rb:38:in dispatch' ../config/../vendor/rails/railties/lib/fcgi_handler.rb:150:inprocess_request’
…/config/…/vendor/rails/railties/lib/fcgi_handler.rb:54:in process!' ../config/../vendor/rails/railties/lib/fcgi_handler.rb:53:ineach_cgi’
/usr/lib/ruby/1.8/fcgi.rb:597:in each' /usr/lib/ruby/1.8/fcgi.rb:597:ineach_cgi’
…/config/…/vendor/rails/railties/lib/fcgi_handler.rb:53:in process!' ../config/../vendor/rails/railties/lib/fcgi_handler.rb:23:inprocess!’
dispatch.fcgi:34

Has anything changed with permissions or something with the
production.log file. It seems that it’s looking for that file and it’s
not there and not creating it. Another thought, complete stab in the
dark is checking enviroment.rb to see if something concerning logging
occured.

I’m assuming this problem is solely because logging stopped working.

It must of been a dreamhost issue because the app started working again
without my intervention.

Joshua S. wrote:

Has anything changed with permissions or something with the
production.log file. It seems that it’s looking for that file and it’s
not there and not creating it. Another thought, complete stab in the
dark is checking enviroment.rb to see if something concerning logging
occured.

I’m assuming this problem is solely because logging stopped working.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs