Multiple rails sites, one domain


#1

Dear list:

Lighttpd just released a new version 1.4.8. Following the tutorial here
(
http://blog.lighttpd.net/articles/2005/11/23/lighttpd-1-4-8-and-multiple-rails-apps
),
I have got that part set up correctly. (ie, mydomain.com/app1 and
mydomain.com/app2 point where they should.) However, all links inside
the
rails app that were generated by rails using link_to,
stylesheet_link_tag,
etc point to the wrong place. For example,

<%= stylesheet_link_tag ‘style’ %>

gives me <a href="/stylesheets/style.css" … which doesnt exist; I
need
href="/app1/stylesheets/style.css" . I’m pretty sure this is done
somehow in
routes.rb, but I’m not sure how, and my experiments at best dont solve
it and
at worst cause lighty to jump to 100% cpu usage and has to be HUP’d. I
can’t
find much in the docs that is useful either. #rubyonrails also had many
useful suggestions, but with the same effects. I was hoping some of the
enlightened souls on this list could point me in the right direction.

Looking at the code for Actionview::TagHelper, I cant see how the href
option
would get the data out of routes.rb, so maybe im going about this the
wrong
way.

Thanks
Paul


#2

Heh, reading the thread immedietly previous this one provides the
solution:
put :

ActionController::AbstractRequest.relative_url_root = “/app”

In one of the environment files. Perhaps this should be documented
somewhere?
api.rubyonrails.com is incorrect, and states this only applies to
apache, as well.