Multimode.py Wrong device arguments specified. Missing nchan?

Hi,
Trying to get multimode running on a virtual machine (VMware) with
Ubuntu
12.04.

My rtlsdr device is connected to rtl_tcp server at 192.168.0.99 port
1234.

Because of the message “FATAL: Wrong rtlsdr device index given.” and the
fact that there is no rtlsdr device connected to the VM so it has to
connect to the rtl_tcp server I did change the multimode.py

def init(self, ahw=“default”, freq=150.0e6, ppm=0.0, vol=1.0,
ftune=0.0, xftune=0.0, srate=1.0e6, upclo=0.0, devinfo=“rtl_tcp
192.168.0.99:1234 “, agc=0, arate=48.0e3, upce=0, mthresh=-10.0,
offs=50.e3, flist=””, dfifo=“multimode_fifo”, mbw=2.0e3, deemph=75.0e-6,
dmode=“NFM1”):

and

type=“string”, default=“rtl_tcp 192.168.0.99:1234”,
help=“Set Device Information [default=%default]”)

The wrong device index message disappeared but there is one error left

Traceback (most recent call last):
File “ben.py”, line 1101, in
tb = multimode(ahw=options.ahw, freq=options.freq, ppm=options.ppm,
vol=options.vol, ftune=options.ftune, xftune=options.xftune,
srate=options.srate, upclo=options.upclo, devinfo=options.devinfo,
agc=options.agc, arate=options.arate, upce=options.upce,
mthresh=options.mthresh, offs=options.offs, flist=options.flist,
dfifo=options.dfifo, mbw=options.mbw, deemph=options.deemph,
dmode=options.dmode)
File “ben.py”, line 488, in init
self.osmosdr_source_c_0 = osmosdr.source_c( args=“nchan=” + str(1) +
"
" + devinfo )
File “/usr/local/lib/python2.7/dist-packages/osmosdr/osmosdr_swig.py”,
line 1309, in source_c
return _osmosdr_swig.source_c(args)
RuntimeError: Wrong device arguments specified. Missing nchan?

Do I have to specify nchan myself, and if, where do I place the value ?

Thanks for your help,
Ben

On 12/06/2012 07:30 AM, Ben Z en de rest wrote:

def init(self, ahw=“default”, freq=150.0e6, ppm=0.0, vol=1.0,

deemph=options.deemph, dmode=options.dmode)

Thanks for your help,
Ben


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
You know that you can pass those parameters ON THE COMMAND LINE, when
you start up multimode – no need to modify code.

multimode.py --devinfo “whatever” for example

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs