Multichannel problem

Hello everyone,

I have posted a similar question before but didnt get too much attention
thats why I am posting this question with hopes that I will get some
response this time because I have tried to make the question simpler.

In one line the problem is I am so far unable to configure 2 RX channels
with RFX2400+USRP1. I have read mostly related mails on this forum and
GNURadio examples as well, I am doing exactly what is mentioned in all
these
but still no success. To understand the problem please read the
following.

I implemented spectrum sensing, first with single RX channel (it works),
and
then I modified it for 2 RX channels and here I have problems.

I first tried sensing with a single channel (This code is well known and
some where available on this forum or GNURadio examples), it is working
fine. In this code I simply display the maximum value of each FFT scan.
When
I have some data source at the frequency which I have set (2.41GHz at
the
moment) then I can easily see it.

This code is attached as “sensing_single_RX_channel.py” at the end

Then I changed this code for two RX channels, one one path I kept the
same
graph for sensing and the output of other graph is sent to a file. If I
forget the output of file for the time being and focus on other leg of
the
graph i.e. spectrum sensing even then my sensed signal is too weak. For
example if with one RX version I was receiving value ‘75’ then now I am
receiving only ‘10’!!!

This 2 RX channel version is also attached as “sensing_2_RX_channel.py”

Its very easy to run these files on your system.

Can some one help me to find what is the problem.

Thanks
http://www.nabble.com/file/p24374390/sensing_single_RX_channel.py
sensing_single_RX_channel.py
http://www.nabble.com/file/p24374390/sensing_2_RX_channel.py
sensing_2_RX_channel.py

View this message in context:
http://www.nabble.com/Multichannel-problem-tp24374390p24374390.html
Sent from the GnuRadio mailing list archive at Nabble.com.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs