Multi-Usrp setup

I am attempting to get a functioning setup with multiple USRP’s working
here, and am running into some difficulty. I have two recent (rev4)
USRP’s with RFX2400 daughtercards connected to a laptop running Ubuntu.
I am able to talk to either individually (using usrp_fft.py, and other
example code, etc.), but cannot get the multi_usrp_oscope.py program to
work. I have connected the boards using a coax cable into an SMA
connector on J2002/2001 as described at
http://www.gnuradio.org/trac/wiki/USRPClockingNotes
According to that same page recent RFX boards do not require additional
connectors, so I assume I am set with regards to connectors.
However, when I run multi_usrp.py (once selecting the master serial
number - it does not appear to matter which one I select as master), the
scope screen comes up but does not display anything (all the buttons,
etc. are there, but nothing appears in the graph). Attempting to exit
hangs the program, and I have to kill it manually (i.e. kill -9 ).

I was running this with gnuradio-3.1.2 (on an ubuntu - hardy heron
install). I have also tried using the latest svn code (after modifying
the code to use toplevel/hier_block2 - which I was having trouble
getting working).

Any suggestions, or hints?
Thanks,
Doug

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs