Mono MVC Timeout

Hi everyone!

I am struggling to get a (simple) MVC app work under OpenBSD (5.3) +
(2.10.9) + Nginx (1.2.6)

I can get a simple index.aspx (Hello World) app to work, but the default
MVC 3 template doesn’t seem to work.

I made some minor changes to remove any reference to SQL providers in
Web.config and I removed EntityFramework.dll, as well as ensuring that
various System.Web.* dlls also co-existed in my \bin folder.

All I seem to get is this:

504 Gateway Time-out

This is how I am launching fastcgi-mono-server4:
fastcgi-mono-server4 /applications/:.

But the only log detail I get is this:
[DateTimeStamp] Beginning to receive records on connection.

I have uploaded my config and source code to here:

Given that I can serve a simple ‘Hello World’ page, I’m pretty sure
isn’t anything wrong with my base nginx/mono installs, but no doubt
something subtle I have missed in my configs. Can anyone (please) shed
light on this?


How soon after making a request do you see the 504 and how does it
relate to your fastcgi_read_timeout setting?

[ Whilst I might have been able to check your config for this, I’m not
going to bother to download a random rar file and unpack it. Learn to
pastebin/gist/etc! :wink: ]


Jonathan M. // Oxford, London, UK



mono --version

Mono JIT compiler version 2.10.9

nginx -V

nginx version: nginx/1.4.4

i have exactly the same problem, i run the aspx with a very explicit

fastcgi-mono-server4 /applications=grey:/index.aspx:./moon/index.aspx

/socket=tcp: /loglevels=Debug /verbose=True

I use this nginx http conf :

server {
server_name grey;
root /var/www/moon/;
index index.html index.htm index.aspx default.aspx;

location = /favicon.ico {
log_not_found off;
access_log off;

location = /robots.txt {
allow all;
log_not_found off;
access_log off;

location / {
fastcgi_index index.aspx;
include fastcgi_params;
fastcgi_param PATH_INFO “”;
fastcgi_param SCRIPT_FILENAME
#try_files $uri $uri/ /index.aspx;

Fighting with ImageCache? This little gem is amazing.

location ~ ^/sites/.*/files/imagecache/ {
try_files $uri $uri/ @rewrite;

Then i copied-pasta the MVC application, expecting the /bin to be

fastcgi-mono-server4 /applications=grey:/:./moon/MonoWeb

/socket=tcp: /loglevels=Debug /verbose=True

i also ran as root and using tcp socket to just test the xsp.

The fastcgi-mono-server4 just say nothing , nor reply the request.

Best regards.

Posted at Nginx Forum:,239541,249838#msg-249838

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs