Mongrel su Debian

sto provando ad installare mongrel su Debian etch tramite Gems:

ecco il risultato:

nathan:/home/bonzo# gem install mongrel
Bulk updating Gem source index for: http://gems.rubyforge.org
Select which gem to install for your platform (i486-linux)

  1. mongrel 1.0.1 (mswin32)
  2. mongrel 1.0.1 (ruby)
  3. mongrel 1.0 (mswin32)
  4. mongrel 1.0 (ruby)
  5. mongrel 0.3.13.4 (ruby)
  6. mongrel 0.3.13.3 (ruby)
  7. mongrel 0.3.13.3 (mswin32)
  8. mongrel 0.3.13.2 (mswin32)
  9. mongrel 0.3.13.2 (ruby)
  10. mongrel 0.3.13.1 (ruby)
  11. mongrel 0.3.13.1 (mswin32)
  12. mongrel 0.3.13 (ruby)
  13. mongrel 0.3.13 (mswin32)
  14. mongrel 0.3.12.4 (ruby)
  15. mongrel 0.3.12.4 (mswin32)
  16. mongrel 0.3.12.3 (mswin32)
  17. mongrel 0.3.12.3 (ruby)
  18. mongrel 0.3.12.2 (mswin32)
  19. mongrel 0.3.12.2 (ruby)
  20. mongrel 0.3.12.1 (mswin32)
  21. mongrel 0.3.12.1 (ruby)
  22. mongrel 0.3.12 (mswin32)
  23. mongrel 0.3.12 (ruby)
  24. mongrel 0.3.11 (mswin32)
  25. mongrel 0.3.11 (ruby)
  26. mongrel 0.3.10.1 (ruby)
  27. mongrel 0.3.10 (ruby)
  28. mongrel 0.3.9 (ruby)
  29. mongrel 0.3.8 (mswin32)
  30. mongrel 0.3.8 (ruby)
  31. mongrel 0.3.7.1 (ruby)
  32. mongrel 0.3.7.1 (mswin32)
  33. mongrel 0.3.7 (ruby)
  34. mongrel 0.3.6 (mswin32)
  35. mongrel 0.3.6 (ruby)
  36. mongrel 0.3.5 (mswin32)
  37. mongrel 0.3.5 (ruby)
  38. mongrel 0.3.4 (mswin32)
  39. mongrel 0.3.4 (ruby)
  40. mongrel 0.3.3 (ruby)
  41. mongrel 0.3.2 (ruby)
  42. mongrel 0.3.1 (ruby)
  43. mongrel 0.3 (ruby)
  44. mongrel 0.2.2 (ruby)
  45. mongrel 0.2.1 (ruby)
  46. mongrel 0.2.0 (ruby)
  47. Cancel installation

2
Install required dependency daemons? [Yn] y
Install required dependency fastthread? [Yn] y
Select which gem to install for your platform (i486-linux)

  1. fastthread 1.0 (ruby)
  2. fastthread 1.0 (mswin32)
  3. fastthread 0.6.4.1 (ruby)
  4. fastthread 0.6.4.1 (mswin32)
  5. fastthread 0.6.3 (ruby)
  6. fastthread 0.6.3 (mswin32)
  7. fastthread 0.6.2 (ruby)
  8. fastthread 0.6.2 (mswin32)
  9. Cancel installation

1
Building native extensions. This could take a while…
extconf.rb:1:in `require’: no such file to load – mkmf (LoadError)
from extconf.rb:1

ERROR: While executing gem … (RuntimeError)
ERROR: Failed to build gem native extension.
Gem files will remain installed in /var/lib/gems/1.8/gems/fastthread-1.0
for
ins pection.

Results logged to
/var/lib/gems/1.8/gems/fastthread-1.0/ext/fastthread/gem_make.
out

Qualcuno sa cosa non va?

Qualcuno sa cosa non va?

Forse ti manca il pacchetto ruby1.8-dev: /usr/lib/ruby/1.8/mkmf.rb


David N. Welton
http://www.welton.it/davidw/

DedaSys LLC
http://www.dedasys.com

On 8/21/07, David W. [email protected] wrote:

Qualcuno sa cosa non va?

Forse ti manca il pacchetto ruby1.8-dev: /usr/lib/ruby/1.8/mkmf.rb

senza il forse :slight_smile:

michele


SeeSaw | Intuitive web stuff


[email protected]

Grazie mille, ora funziona.
Bonzo

Il 21/08/07, Michele F. [email protected] ha scritto:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs