Mongrel_service install error

when I run ‘gem install mongrel_service’…it gives following error…

Building native extensions. This could take a while…
ERROR: Error installing mongrel_service:
ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb install mongrel_service
checking for RegisterServiceCtrlHandlerEx()… no
checking for EnumServicesStatusEx()… no
checking for QueryServiceStatusEx()… no
creating Makefile

Gem files will remain installed in
c:/ruby/lib/ruby/gems/1.8/gems/win32-service-
0.5.2 for inspection.
Results logged to
c:/ruby/lib/ruby/gems/1.8/gems/win32-service-0.5.2/gem_make.out

On Jan 30, 2008 4:35 AM, Vapor … [email protected] wrote:

creating Makefile

it seems you’re running version 0.9.5 of RubyGems, please update to
1.0.1 and uninstall the offending gems.

I’ve described this issue in a blog post:

http://blog.mmediasys.com/2007/12/19/latest-rubygems-and-rails-is-a-deadly-combo/

And a few times on ruby-talk:

http://groups.google.com/group/comp.lang.ruby/browse_thread/thread/a594343b8ada2cc3

HTH,

Luis L.
Multimedia systems

A common mistake that people make when trying to design
something completely foolproof is to underestimate
the ingenuity of complete fools.
Douglas Adams

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs