Mongrel service error

He actualizado mis gemas y hubo unas cuantas que estaban “atrasadas”,
algunas de ellas son mongrel, windows-service.

Pero ahora cuando intento installar el servicio de mongrel en windows,
me da un error.

Puedo correr el servidor normalmente (mongrel_rails start o
script/server) pero no puedo instalar el servicio.

El error que me da es este: http://pastie.caboo.se/135004

Alguien tiene alguna sugerencia? Gracias

a mi me estaba dando el mismo problema es mas ni me dejaba arrancar la
instacion con gem o cualquier instruccin que incluyera gem asi que en
esta
lista me pasaron este post, lo copio y pego ya que el que investigo y
soluciono esto fue Juanma Cercera

El día 2/01/08, Juanma C. [email protected]
escribió:

Un saludo
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es

El día 4/01/08, Edgar J. Suarez [email protected]
escribió:

El error que me da es este: http://pastie.caboo.se/135004

Alguien tiene alguna sugerencia? Gracias

Posted via http://www.ruby-forum.com/.


Ror-es mailing list
[email protected]
http://lists.simplelogica.net/mailman/listinfo/ror-es

Mauricio Dulcce

+57 300 325 0335
Trasn 9c No. 130c-21
Bogotá, Colombia

Privileged/Confidential Information may be contained in this message. If
you

are not the addressee indicated in this message or responsible for
delivery
of the message to such person), you may not copy or deliver this message
to
anyone. In such case, you should destroy this message and kindly notify
the
sender by reply email. Please advise immediately if you or your employer
do
not consent to Internet email for messages of this kind. Opinions,
conclusions and other information in this message that do not relate to
the
official business of my firm shall be understood as neither given nor
endorsed by it.

Pero según leo el error es diferente al que yo tengo.

No creo tener problemas con mis gems, más bien marca un ArgumentError,
no sé si la nueva versión de Win32-Service pida parámetros obligatorios.
Según lo que he indagado en el código, asi es.

Y también he cambiado la línea que crea el servicio satisfaciendo los
parámetros que debería llevar, pero sigue sin funcionar.

El error que me sale al cambiar la linea 140 del lib/init.rb en el
mongrel_service: http://pastie.caboo.se/135139

Edgar J. Suarez wrote:

Pero según leo el error es diferente al que yo tengo.

No creo tener problemas con mis gems, más bien marca un ArgumentError,
no sé si la nueva versión de Win32-Service pida parámetros obligatorios.
Según lo que he indagado en el código, asi es.

Y también he cambiado la línea que crea el servicio satisfaciendo los
parámetros que debería llevar, pero sigue sin funcionar.

El error que me sale al cambiar la linea 140 del lib/init.rb en el
mongrel_service: http://pastie.caboo.se/135139

Al parecer el problema es con las versiones de Win32-Service y
mongrel_service, así que para los que lo usan, tengan cuidado de no
hacer un gem update porque les actualizará todas sus gemas y empezará a
dar error.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs