Mongrel_rails and mongrel_cluster start error

Hello everyone,

I cannot get mongrel_rails or mongrel_cluster working fine. When I try
to to launch one of them, I always get the same error:

mongrel_rails start -p 8080 -e production -c /var/www/domain.com/

www/current -P /var/www/domain.com/www/current/log/mongrel.pid

** Ruby version is not up-to-date; loading cgi_multipart_eof_fix
** Starting Mongrel listening at 0.0.0.0:8080
** Starting Rails with production environment…
/usr/lib/ruby/1.8/yaml.rb:133:in load': syntax error on line 33, col 0: ’ (ArgumentError)
from /usr/lib/ruby/1.8/yaml.rb:133:in load' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ initializer.rb:523:indatabase_configuration’
from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/
initializer.rb:228:in initialize_database' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ initializer.rb:88:inprocess’
from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/
initializer.rb:43:in send' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/ initializer.rb:43:inrun’
from /var/www/gn2.fr/www/current/config/environment.rb:20
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
27:in gem_original_require' ... 10 levels... from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/lib/mongrel/ command.rb:211:inrun’
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.0.1/bin/
mongrel_rails:243
from /usr/bin/mongrel_rails:16:in `load’
from /usr/bin/mongrel_rails:16

I am using ruby 1.8.5, rails 1.2.3, mongrel 1.0.1, and I tried
mongrel_cluster 1.0.2 and 0.2.1.

Do you know what I could have wrong?

Thank you very much in advance !
Adrien.

check the mongrel log to see if it has any more information… also
check that your database.yml doesn’t have a syntax error

Ok, I remembered that I installed libmysql-ruby1.8 today on my server.
I remembered that when you told me to check my database.yml.
I tried to uninstall it, and now, everything works !

However I don’t really understand the link between this lib and
mongrel…

Thank you very much for your help !
Adrien.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs