Mongrel not wanting to start... any ideas?


#1

I’m in the process of moving an old Rails app to a new server and i
can’t seem to get mongrel to start.

I issue the command:
mongrel_rails start

and I get this:
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment …
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
require__': no such file to load -- ruby-debug (MissingSourceFile) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
from
/home/vhosts/dealer.benningtonmarine.com/config/…/vendor/rails/activerecord/lib/…/…/activesupport/lib/active_support/dependencies.rb:147:in
require' from /home/vhosts/dealer.benningtonmarine.com/config/environment.rb:68 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire’
from
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/rails.rb:144:in
rails' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:112:incloaker_’
from
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:832:in
listener' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:96:incloaker_’
from
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:750:in
initialize' from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:83:inrun’
from
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/command.rb:199:in
`run’
from
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:235
from /usr/local/bin/mongrel_rails:18

I should note that this app is Ruby V 1.8.4 and Rails V 1.1.6 and
Mongrel V 0.3.13.3

Thanks in advance for any assistance or guidance you may be able to
provide.


#2

It likes that you don’t have a ruby-debug gem (perhaps you forgot any
“debugger” in your app).
Try installing it: gem install ruby-debug

Rusty Rustybucket wrote:

require__': no such file to load -- ruby-debug (MissingSourceFile) fromcloaker_’
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:235
from /usr/local/bin/mongrel_rails:18

I should note that this app is Ruby V 1.8.4 and Rails V 1.1.6 and
Mongrel V 0.3.13.3

Thanks in advance for any assistance or guidance you may be able to
provide.


Rafa