Mongrel not starting

Hello all,
I’m have a problem starting Mongrel.

I get the following…

user-fc0e6f:ProjectDB johnmcleod$ script/server mongrel
^C/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/gems.rb:11:in
require': Interrupt from /Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel.rb:17 from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:ingem_original_require’
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in require' from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:inrequire’
from
/Library/Ruby/Gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
new_constants_in' from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:inrequire’
from
/Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler/mongrel.rb:1
from /Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler.rb:17:in
const_get' from /Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler.rb:17:inget’
from /Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler.rb:17:in
each' from /Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler.rb:17:inget’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:45
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from script/server:3

I’m not sure where to go from here. I’ve uninstalled and reinstalled via
“sudo gem install mongrel”

I have
rack-1.0.0
rack-1.0.1
rack-1.1.0
installed.

if that helps.

Thank you for any help with this.

JohnM

Maybe a gem list would help too.

  • Gems -

*** LOCAL GEMS ***

acl9 (0.12.0)
actionmailer (2.3.5, 2.3.4, 2.2.2, 1.3.6)
actionpack (2.3.5, 2.3.4, 2.2.2, 1.13.6)
actionwebservice (1.2.6)
activerecord (2.3.5, 2.3.4, 2.2.2, 1.15.6)
activerecord-oracle-adapter (1.0.0.9250)
activeresource (2.3.5, 2.3.4, 2.2.2)
activesupport (2.3.5, 2.3.4, 2.2.2, 1.4.4)
acts_as_ferret (0.4.4, 0.4.3)
amatch (0.2.5)
authlogic (2.1.3)
bmabey-fakefs (0.1.1.1)
builder (2.1.2)
cancan (1.0.2)
capistrano (2.5.17, 2.5.11, 2.5.9, 2.5.2)
cgi_multipart_eof_fix (2.5.0)
columnize (0.3.1)
cucumber (0.6.1, 0.4.4, 0.4.0)
daemons (1.0.10)
diff-lcs (1.1.2)
dnssd (1.3.1, 1.3, 0.6.0)
eventmachine (0.12.10, 0.12.8)
extjs-mvc (0.2.8, 0.2.5)
fastercsv (1.5.0)
fastthread (1.0.7, 1.0.1)
fcgi (0.8.8, 0.8.7)
ferret (0.11.6)
formtastic (0.9.7)
gem_plugin (0.2.3)
gemcutter (0.2.1, 0.1.6)
has_many_through_generator (0.4.0)
highline (1.5.1, 1.5.0)
hirb (0.2.9)
hpricot (0.8.2, 0.8.1, 0.6.164)
json_pure (1.2.0, 1.1.9)
libxml-ruby (1.1.3, 1.1.2)
linecache (0.43)
markaby (0.5)
metaid (1.0)
mislav-will_paginate (2.3.11)
mongrel (1.1.5)
mysql (2.8.1)
needle (1.3.0)
net-scp (1.0.2, 1.0.1)
net-sftp (2.0.4, 2.0.2, 2.0.1, 1.1.1)
net-ssh (2.0.17, 2.0.15, 2.0.4, 1.1.4)
net-ssh-gateway (1.0.1, 1.0.0)
nifty-generators (0.3.0)
nokogiri (1.4.1, 1.4.0)
paperclip (2.3.1.1)
ParseTree (3.0.4)
passenger (2.2.8, 2.2.7, 2.2.5)
polyglot (0.2.9)
rack (1.1.0, 1.0.1, 1.0.0)
rails (2.3.5, 2.3.4, 2.2.2, 1.2.6)
rake (0.8.7, 0.8.3)
RedCloth (4.2.2, 4.1.1)
rspec (1.2.9)
rspec-rails (1.2.9)
ruby-debug (0.10.3)
ruby-debug-base (0.10.3)
ruby-debug-ide (0.4.9)
ruby-openid (2.1.7, 2.1.2, 2.0.4)
ruby-yadis (0.3.4)
ruby2ruby (1.2.4)
ruby_parser (2.0.4)
rubyforge (2.0.3, 2.0.2)
rubygems-update (1.3.5)
rubynode (0.1.5)
searchlogic (2.3.9)
sqlite3-ruby (1.2.5, 1.2.4)
term-ansicolor (1.0.4)
termios (0.9.4)
text (0.1.13)
treetop (1.4.3, 1.4.2)
webrat (0.6.0)
xmpp4r (0.5, 0.4)

Thanks again

John

On Mar 3, 2:58 pm, John M. [email protected] wrote:

Hello all,
I’m have a problem starting Mongrel.

I get the following…

user-fc0e6f:ProjectDB johnmcleod$ script/server mongrel
^C/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/gems.rb:11:in
`require’: Interrupt

Interrupt usually means that you killed it (eg control-C). DId you ?

Fred

On 3 March 2010 16:19, John M. [email protected] wrote:

Thank you for the reply.

Yes, after 1 minute of nothing.

John

Nothing?

You’re going to have to help us to help you:
How are you trying to start it? (command line? in an IDE? in a script?)
What gets displayed? (** Starting Mongrel listening at 0.0.0.0:3000,
etc)
What OS are you on?!

Michael

Thank you for the reply.

Yes, after 1 minute of nothing.

John

Sorry about that.

OS: Mac

At the rails project root directory, using the Terminal, “script/server
mongrel”.

When I say “nothing” I mean a blank screen. The cursor goes to the next
line and that’s it.

I’ve also used “ruby script/server mongrel -debug” with the same
results.

When I interrupt the process (CTRL+C), I’ve been getting this…

user-fc0e6f:ProjectDB johnmcleod$ ruby script/server mongrel -debug
^C/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/gems.rb:11:in
require': Interrupt from /Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel.rb:17 from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:ingem_original_require’
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36:in require' from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:inrequire’
from
/Library/Ruby/Gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
new_constants_in' from /Library/Ruby/Gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:inrequire’
from
/Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler/mongrel.rb:1
from /Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler.rb:17:in
const_get' from /Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler.rb:17:inget’
from /Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler.rb:17:in
each' from /Library/Ruby/Gems/1.8/gems/rack-1.0.1/lib/rack/handler.rb:17:inget’
from /Library/Ruby/Gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:45
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
gem_original_require' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:inrequire’
from script/server:3

Thanks for the reply.

John

Thank you for everyone’s reply.

I finally made it work.

Here’s the steps I did.

sudo gem uninstall mongrel
sudo gem uninstall fastthread
sudo gem install mongrel
sudo gem install fastthread

As I’m not that experienced with this, I’ll assume that one or the other
installation was bad.

I found the solution here:
http://stackoverflow.com/questions/1350486/ruby-on-rails-staring-mongrel-server

Thanks again.

John

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs