Mongrel - Missing required gems - but THEY ARE THERE!

Hi guys,

the strangest thing is all the below was not happening before this
latest deployment, attempting to use Capistrano, didn’t work so manually
deploying.


RUBYGEMS VERSION: 1.3.1
RUBY VERSION: 1.8.6
Rails 2.3.2


Now I am using formtastic gem for my forms.
in my environment.rb I have:
config.gem ‘justinfrench-formtastic’, :lib => ‘formtastic’, :source =>
http://gems.github.com

works fine locally of course, and funny it worked the first deployment
on the same host. (Joyent shared accelerator)

Now when i deploy and restart mongrel, here’s what I get in a loop:


** Starting Rails with production environment…
Missing these required gems:
justinfrench-formtastic

You’re running:
ruby 1.8.6.368 at /usr/local/bin/ruby18
rubygems 1.3.1 at /.gem/ruby/1.8, /usr/local/lib/ruby/gems/1.8

Run rake gems:install to install the missing gems.


Now when I check my gems
rake gems
it prints


  • [I] justinfrench-formtastic

I = Installed
F = Frozen
R = Framework (loaded before rails starts)


so the gems is there right!?
I mean it was installed before the very first deployment.
and now if i run rake gems:install
nothing happens!
rake gems:install --trace
** Invoke gems:install (first_time)
** Invoke gems:base (first_time)
** Execute gems:base
** Invoke environment (first_time)
** Execute environment
** Execute gems:install

I can also see the gem listed in the “gem list”
*** LOCAL GEMS ***

justinfrench-formtastic (0.2.4)

So not sure what is happening :S

Why can’t mongrel find the gem if it is installed an was working fine
before!
Where should i even start looking! :S

Driving me nuts for days now! please help!!
thanks

probably a path issue.

try re-installing, or updating the $Path

Bac

probably a path issue.

try re-installing, or updating the $Path

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs