MissingSourceFile: no such file to load -- login_engine

This error seems to stem from the require line in application.rb. I’m
new to Rails, but I’m assuming that this should load the
lib/login_engine.rb from within the vendor/plugins/login_engine

I’ve been over the install docs several times and followed along with
the login engine demonstration video. I must have missed something
crucial along the way but I can’t find it. Any idea what it might be?

$ ruby --version
ruby 1.8.4 (2005-12-24)

$ rails --version
Rails 1.1.2

both engines and login_engines have been installed with script/plugin

I suppose I should add, this is the error I get when accessing



no such file to load – login_engine

RAILS_ROOT: script/…/config/…
Application Trace | Framework Trace | Full Trace

require__' /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in require’

This error occured while loading the following files:

Problem Solved:

Server needs to be restarted after any edits to environments.rb

Eli M. wrote:

Problem Solved:

Server needs to be restarted after any edits to environments.rb

Solution to the problem that worked for me:

When you go to http://localhost:3000/ page then click on the “About your
application environment” link to see if the things are working for you.

If it says about the sqlite3 missing problem then you need to install
sqlite3 plugin using gem. I got the problem using sqlite3 as well as

Using mysql(mysql installed in advance)
created application using : rails -d mysql demo
you need to make appropriate changes to config/database.yml file such as
user name ( I kept the user name as root while configuring mysql) and
password of the “development environment” only( no need to do anything
in production or test) as well provide the name of the database which
you can create using mysql client.

mysql>CREATE DATABASE mydiary;

I hope the same applies using sqlite3.

Sulabh J.