Missing required 'path' module?

Hi,

I hope this is the coorect list to post this type of query to. If not
please let me know to where it should be directed.

I am running Ubuntu 6.06 with ruby 1.8.4, rails 1.1.6 and gem 0.8.11

I have created an empty application and added the method ‘hello’ to the
controller. When I try to access this in webbrick my broswer page is
blank and the output from the server is:

127.0.0.1 - - [19/Nov/2006:10:37:09 SAST] “GET /grope/hello HTTP/1.1”
200 0

  • -> /grope/hello
    [2006-11-19 10:37:09] ERROR MissingSourceFile: no such file to load –
    irb
    /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
    require__' /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
    require' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/breakpoint.rb:18 /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:140:inload’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:56:in
    require_or_load' /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:30:independ_on’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:85:in
    require_dependency' /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:98:inconst_missing’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:131:in
    const_missing' /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:133:inconst_missing’
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/dispatcher.rb:75:in
    reset_after_dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/dispatcher.rb:46:indispatch’
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/webrick_server.rb:115:in
    handle_dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/webrick_server.rb:81:inservice’
    /usr/lib/ruby/1.8/webrick/httpserver.rb:104:in service' /usr/lib/ruby/1.8/webrick/httpserver.rb:65:inrun’
    /usr/lib/ruby/1.8/webrick/server.rb:173:in start_thread' /usr/lib/ruby/1.8/webrick/server.rb:162:instart_thread’
    /usr/lib/ruby/1.8/webrick/server.rb:95:in start' /usr/lib/ruby/1.8/webrick/server.rb:92:instart’
    /usr/lib/ruby/1.8/webrick/server.rb:23:in start' /usr/lib/ruby/1.8/webrick/server.rb:82:instart’
    /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/webrick_server.rb:67:in
    dispatch' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/servers/webrick.rb:59 /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
    require' /usr/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/server.rb:30 /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in
    `require’
    script/server:3

If I look in custom_require.rb is appears that I am missing the package
‘path’.

What am I missing here? And what do I need to do to correct it?


mike kenny
Linux Registered User #381724
LPI ID# 80080

“Hell, there are no rules here, we’re just trying to accomplish
something”
Thomas Edison

Mike A. Kenny wrote:

Hi,

I hope this is the coorect list to post this type of query to. If not
please let me know to where it should be directed.

I am running Ubuntu 6.06 with ruby 1.8.4, rails 1.1.6 and gem 0.8.11

I have created an empty application and added the method ‘hello’ to the
controller.

Please show us your code and the specifics of how you are storing and
then
calling your application.

Mike A. Kenny wrote:

    /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:in

Hey Mike,
my guess is you need to install irb - properly something like: apt-get
install irb

/Kevin

On Nov 19, 2006, at 12:41 AM, Mike A. Kenny wrote:

127.0.0.1 - - [19/Nov/2006:10:37:09 SAST] “GET /grope/hello HTTP/
1.1” 200 0

  • -> /grope/hello
    [2006-11-19 10:37:09] ERROR MissingSourceFile: no such file to load
    – irb

If I look in custom_require.rb is appears that I am missing the
package ‘path’.

No, you’re missing irb.

What am I missing here? And what do I need to do to correct it?

You haven’t performed a full install of ruby.


Eric H. - [email protected] - http://blog.segment7.net
This implementation is HODEL-HASH-9600 compliant

http://trackmap.robotcoop.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs