Missing openssl.so in x86_64-linux/

Hi,

I am running centos 5.0 (64 bit) and want to run ruby 1.8.6 and rails.

I installed 1.8.6 from source using:
wget ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.6-p114.tar.gz
tar xfz ruby-*
cd ruby-*
./configure --prefix=/usr --enable-pthread --with-readline-dir=/usr/
local --enable-shared
make
sudo make install

Ruby seems to be there and ok,

ruby -v
ruby 1.8.6 (2008-03-03 patchlevel 114) [x86_64-linux]

but when I try to start my rails server, it complains:

/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in
`require_frameworks’: no such file to load – openssl.so
(RuntimeError)

When I look in:
/usr/lib/ruby/1.8/x86_64-linux/ - there is no open ssl library

but when I look in:
/usr/lib/ruby/1.8/i386-linux/openssl.so it is there , I tried copying
it over, but it didnt like that version.

any ideas?

Also is it possible just to force using the 32 bit version of ruby
even on this install?

thanks
Joel

On Sat, 2008-04-12 at 10:30 +0900, joelkeepup wrote:

make
`require_frameworks’: no such file to load – openssl.so
(RuntimeError)

When I look in:
/usr/lib/ruby/1.8/x86_64-linux/ - there is no open ssl library

but when I look in:
/usr/lib/ruby/1.8/i386-linux/openssl.so it is there , I tried copying
it over, but it didnt like that version.

any ideas?

Did you had openssl library and its devel package installed before
compiling Ruby?

On Apr 11, 11:27 pm, hemant kumar [email protected] wrote:

local --enable-shared
/usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in
any ideas?
Joel
yes, have both, it wouldnt have created the 32 bit version if I didnt
(I dont think)

~] rpm -qa | grep openssl
openssl-0.9.8b-8.3.el5_0.2
openssl-0.9.8b-8.3.el5_0.2
openssl-devel-0.9.8b-8.3.el5_0.2

any other ideas?

thanks
Joel

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs