Missing base64 library in Ruby1.9, cannot run cloudkit

Hi,
I install cloudkit. I have followed the steps in the manual
(http://getcloudkit.com/curl.html), but when I execute “rackup
config.ru”, I get this error message:

/usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/helper.rb:2:in
require': no such file to load -- base64 (LoadError) from /usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/helper.rb:2:in<top (required)>’
from
/usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/client/net_http.rb:1:in
require' from /usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/client/net_http.rb:1:in<top (required)>’
from
/usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/consumer.rb:4:in
require' from /usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/consumer.rb:4:in<top (required)>’
from
/usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/client/helper.rb:2:in
require' from /usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/client/helper.rb:2:in<top (required)>’
from
/usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth.rb:10:in
require' from /usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth.rb:10:in<top
(required)>’
from
/usr/lib/ruby1.9/gems/1.9.0/gems/cloudkit-0.11.2/lib/cloudkit.rb:9:in
require' from /usr/lib/ruby1.9/gems/1.9.0/gems/cloudkit-0.11.2/lib/cloudkit.rb:9:in<top (required)>’
from config.ru:1:in require' from config.ru:1:inblock (2 levels) in ’
from
/usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/lib/rack/builder.rb:46:in
instance_eval' from /usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/lib/rack/builder.rb:46:ininitialize’
from config.ru:1:in new' from config.ru:1:in
from
/usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/lib/rack/builder.rb:35:in
eval' from /usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/lib/rack/builder.rb:35:inparse_file’
from
/usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/lib/rack/server.rb:113:in
app' from /usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/lib/rack/server.rb:189:inwrapped_app’
from
/usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/lib/rack/server.rb:155:in
start' from /usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/lib/rack/server.rb:83:instart’
from /usr/lib/ruby1.9/gems/1.9.0/gems/rack-1.1.0/bin/rackup:4:in
<top (required)>' from /usr/bin/rackup:19:inload’
from /usr/bin/rackup:19:in `’

I cannot find somewhere how to fix this error in ruby 1.9, please help
me.

Thanks.

Bejvas Jod wrote:

Hi,
I install cloudkit. I have followed the steps in the manual
(http://getcloudkit.com/curl.html), but when I execute “rackup
config.ru”, I get this error message:

/usr/lib/ruby1.9/gems/1.9.0/gems/oauth-0.4.0/lib/oauth/helper.rb:2:in
`require’: no such file to load – base64 (LoadError)

Try this at the command line:

$ irb19 --simple-prompt

require ‘base64’
=> true

RUBY_DESCRIPTION
=> “ruby 1.9.2dev (2009-07-18 trunk 24186) [i686-linux]”

If it fails, it’s probably because you have an old, development version
of 1.9. Switch forward to 1.9.1 or later, or back to 1.8.7.

Output:

require ‘base64’
LoadError: no such file to load – base64
from (irb):1:in require' from (irb):1 from /usr/bin/irb1.9:12:in

RUBY_DESCRIPTION
=> “ruby 1.9.0 (2008-06-20 revision 17482) [i486-linux]”

I have installed ruby1.9 from debian lenny repositories, it’s bad? Argh
:frowning:
Ok, i try downgrade to 1.8, but I thought that the new version will be
stable :frowning:
Is any other solution other than compile new ruby?

Thanks

Brian C. wrote:

Bejvas Jod wrote:

Is any other solution other than compile new ruby?

Install base64.rb yourself? (Into either your ruby lib dir or your app’s
lib dir)

http://svn.ruby-lang.org/repos/ruby/trunk/lib/base64.rb

Nice, it works, many thanks :slight_smile:

Bejvas Jod wrote:

Is any other solution other than compile new ruby?

Install base64.rb yourself? (Into either your ruby lib dir or your app’s
lib dir)

http://svn.ruby-lang.org/repos/ruby/trunk/lib/base64.rb

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs