Mise à jour de RubyGem impossible


#1

J’ai un soucis… heu… très con.

Sur mon serveur, j’ai une install toute fraîche. ruby, gem, rake,
mongrel,
rails, mysql… tout le toutim. Je crée ma première appli rails, et je
lance
script/serveur.

Erreur :
Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please gem update --system and try again.

Je confirme :

gem -v

1.2.0

Pourtant :

gem update --system

Updating RubyGems
Nothing to update

Vous avez une idée ???

gUI


Pour la santé de votre ordinateur, préférez les logiciels libres.
Lire son mail : http://www.mozilla-europe.org/fr/products/thunderbird/
Browser le web : http://www.mozilla-europe.org/fr/products/firefox/
Suite bureautique : http://fr.openoffice.org/


#2

Le 28 novembre 2008 09:45, Guillaume a écrit :

Vous avez une idée ???
Relire bien attentivement l’annonce ?

http://rubyforge.org/forum/forum.php?forum_id=28071

(à part ça les questions purement Ruby ont un lieu adapté :

http://groups.google.com/group/rubyfr-public )

-- Jean-François.


Rails Party à Paris dimanche 30 novembre !
Infos: http://rubyfrance.org/evenements/rails-party-2008/
Inscriptions: http://railsparty.ror.bearstech.com

http://twitter.com/underflow_


#3

$ sudo gem install rubygems-update
$ update_rubygems

2008/11/28 Guillaume B. removed_email_address@domain.invalid


#4

merci à tous les 2, ça a marché (-:

gUI


Pour la santé de votre ordinateur, préférez les logiciels libres.
Lire son mail : http://www.mozilla-europe.org/fr/products/thunderbird/
Browser le web : http://www.mozilla-europe.org/fr/products/firefox/
Suite bureautique : http://fr.openoffice.org/


#5

Le 28 novembre 2008 10:06, philippe a écrit :

You may have to run the command twice if you have any previosly installed
rubygems-update gems.

Tiens, ça me rappelle la double install des Rails (je sais plus
quelle version) nécessaire pour avoir ActiveResource ou qqchose
comme ça :wink:

Quand AWS a été laissé tomber pour ARes, tu pouvais avoir un
pb pour freezer car les mini-frameworks (au sens Rails du terme)
sont hardcodés dans la tâche Rake, comme tu utilises l’ancienne
tâche Rake (qui forcément, ne prend pas en compte ARes), tu
ne peux utiliser la nouvelle tâche Rake (à jour) qu’après une
première install. Je ne sais pas si je suis clair.

– Jean-François.


Rails Party à Paris dimanche 30 novembre !
Infos: http://rubyfrance.org/evenements/rails-party-2008/
Inscriptions: http://railsparty.ror.bearstech.com

http://twitter.com/underflow_


#6

You may have to run the command twice if you have any previosly installed
rubygems-update gems.

Tiens, ça me rappelle la double install des Rails (je sais plus quelle
version) nécessaire pour avoir ActiveResource ou qqchose comme ça :wink:


#7

Je ne sais pas si je suis clair.

T’inquiètes tu n’as pas un style tarabiscoté comme d’autres :wink: