Minor misleading configure error-msg around PCRE

Hi,

./configure: error: the HTTP rewrite module requires the PCRE library.
You can either disable the module by using
–without-http_rewrite_module
option, or install the PCRE library into the system, or build the PCRE
library
statically from the source with nginx by using --with-pcre=
option.

This happens when not having pcre, using --without-http_rewrite_module
BUT
also --with-pcre as an option, like:
./configure --without-http_rewrite_module --with-pcre

For sure that’s a stupid combination, but just happened in a very long,
generated
configure line here. FWIW, this was on OpenBSD 5.1.

Hello!

On Tue, Oct 29, 2013 at 11:27:48AM +0100,
[email protected] wrote:

This happens when not having pcre, using
–without-http_rewrite_module BUT
also --with-pcre as an option, like:
./configure --without-http_rewrite_module --with-pcre

For sure that’s a stupid combination, but just happened in a very
long, generated
configure line here. FWIW, this was on OpenBSD 5.1.

Actually, this is valid configuration. It will compile nginx
with PCRE support in various places like location matching, but
without the rewrite module.

The error message provided is a bit misleading as it refers to a
module already disabled, but generating proper error messages for
this and similar non-trivial cases is tricky and was considered to
be an overkill.


Maxim D.
http://nginx.org/en/donation.html

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs