./miniruby runruby.rb bin/rdoc --fmt=html does not work

Hi,

I can’t make the html documentation with rdoc during the build.
What could be the problem?

Without debug argument I get
/usr/src/packages/BUILD/ruby/lib/rdoc/template.rb:195: [BUG]
rb_gc_mark(): unknown data type 0x10(0xf4a9118) non object
ruby 1.8.5 (2006-11-01) [i586-linux]

With debug argument
$ ./miniruby runruby.rb bin/rdoc -D --all --line-numbers --charset=UTF-8
–fmt=html -p --inline-source --op=rdoc/html .

[…]
Generating HTML…
Exception `ArgumentError’ at
/usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1103

  • too many arguments for format string
    /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1103:in
    sprintf': too many arguments for format string (ArgumentError) from /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1103:inadd_line_numbers’
    from
    /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1102:in
    gsub!' from /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1102:inadd_line_numbers’
    from
    /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1087:in
    markup_code' from /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:925:ininitialize’
    from
    /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:326:in
    new' from /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:326:incollect_methods’
    from
    /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:326:in
    collect' from /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:326:incollect_methods’
    from
    /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:787:in
    initialize' from /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1256:innew’
    from
    /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1256:in
    build_indices' from /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1255:ineach’
    from
    /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1255:in
    build_indices' from /usr/src/packages/BUILD/ruby/lib/rdoc/generators/html_generator.rb:1196:ingenerate’
    from /usr/src/packages/BUILD/ruby/lib/rdoc/rdoc.rb:284:in
    `document’
    from bin/rdoc:63

Markus K. wrote on 01.11.2006 15:20:

With debug argument
$ ./miniruby runruby.rb bin/rdoc -D --all --line-numbers --charset=UTF-8
–fmt=html -p --inline-source --op=rdoc/html .
[…]

With debug and without line-numbers I get
/usr/src/packages/BUILD/ruby/lib/rdoc/markup/simple_markup/inline.rb:276:
[BUG] rb_gc_mark(): unknown data type 0x10(0xd5d6050) non object

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs