MiniMagick Problems on 64-bit OS

I’m running the following 5 lines of ruby code.


require ‘mini_magick’
include MiniMagick
dir = “C:\users\alex\pictures\”
pic = “#{dir}\Flowers006.jpg”
image = Image.from_file(pic)

I get a host of errors, which are:

C:/Ruby19/lib/ruby/gems/1.9.1/gems/mini_magick-1.2.5/lib/mini_magick.rb:154:in
': Invalid argument - identify C:/Users/Alex/AppData/Local/Temp/mini_magick4704-0. 2>&1 (Errno::EINVAL) from C:/Ruby19/lib/ruby/gems/1.9.1/gems/mini_magick-1.2.5/lib/mini_magick.rb:154:inrun_command’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/mini_magick-1.2.5/lib/mini_magick.rb:47:in
initialize' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/mini_magick-1.2.5/lib/mini_magick.rb:28:innew’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/mini_magick-1.2.5/lib/mini_magick.rb:28:in
from_blob' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/mini_magick-1.2.5/lib/mini_magick.rb:34:inblock in open’
from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/mini_magick-1.2.5/lib/mini_magick.rb:33:in
open' from C:/Ruby19/lib/ruby/gems/1.9.1/gems/mini_magick-1.2.5/lib/mini_magick.rb:33:inopen’
from image.rb:7:in `’

I am running the 64-bit version of Windows 7.

The file and directories definitely exist, and the same code works fine
on my Windows XP 32-bit installation.

Is it possible that I can’t run mini_magick on a 64-bit OS? The
mini_magick gem installed fine, with no errors.

– Alex

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs