MinGW install problem

Sorry if this is a duplicate…email issues.

I have a working version of GNU Radio 3.0.4 on a MinGW system and
noticed that new instructions had been posted for 3.1.2 so thought I’d
give it a shot but ran into the following problem when running the
./bootstrap command just after the makefiles patch:

$ ./bootstrap
configure.ac:21 http://configure.ac:21/ : error: Autoconf version 2.57
or higher is required
configure.ac:21 http://configure.ac:21/ : the top level
autom4te: /bin/m4 failed with exit status: 1
configure.ac:21 http://configure.ac:21/ : error: Autoconf version 2.57
or higher is required
configure.ac:21 http://configure.ac:21/ : the top level
autom4te: /bin/m4 failed with exit status: 1
autoheader: /usr/bin/autom4te failed with exit status: 1
configure.ac:21 http://configure.ac:21/ : error: Autoconf version 2.57
or higher is required
configure.ac:21 http://configure.ac:21/ : the top level
autom4te: /bin/m4 failed with exit status: 1
configure.ac http://configure.ac/ : AM_INIT_AUTOMAKE' must be used automake: your implementation of AM_INIT_AUTOMAKE comes from an automake: old Automake version. You should recreate aclocal.m4 automake: with aclocal and run automake again. configure.ac <http://configure.ac/> : installing./mkinstalldirs’
automake: no `Makefile.am’ found or specified

I’m pretty sure I followed all the instructions up to that point and
used all the correct file versions, but when I did an “autoscan -V” I
saw that I have version 2.56 of autoconf.Can anyone help?

Thanks,

Rob
Rob Walker
Crane Division, Naval Surface Warfare Center (NSWC Crane)
Harnessing the Power of Technology for the Warfighter
300 Highway 361
Crane, IN 47522-5001
Ph: (812) 854-3921 (DSN 482)
Cell: (812) 617-1217
Email: [email protected]


Sent from my BlackBerry Wireless Handheld

Hi everybody,

I’m looking for suggestions on how to implement a variable that is
shared between two blocks.
If I include the same header into the .cc files implementing my blocks
I get the “multiple definition of variable x” error.

Which is the correct way to do this?
is there an example available?

many thanks in advance
vincenzo

Rob Walker wrote:

I have a working version of GNU Radio 3.0.4 on a MinGW system and noticed
that new instructions had been posted for 3.1.2 so thought I’d give it a
shot but ran into the following problem when running the ./bootstrap
command just after the makefiles patch:

$ ./bootstrap
configure.ac:21 http://configure.ac:21/ : error: Autoconf version 2.57
or higher is required
[…]
I’m pretty sure I followed all the instructions up to that point and used
all the correct file versions, but when I did an “autoscan -V” I saw that
I have version 2.56 of autoconf.Can anyone help?

GNU Radio 3.1.2 requires several MSYS/MinGW packages that were not
required
by earlier releases. You need the following:

  • autoconf 2.59 (or later)
  • automake 1.9.5 (or later)
  • libtool 1.5 (or later)

These are available from the sourceforge MinGW/MSYS repository as
autoconf-2.59-mingwPORT.tar.bz2, automake-1.9.5-mingwPORT.tar.bz2, and
libtool-1.5.22-mingwPORT.tar.bz2. To install these, download the files
to
/usr/src, unpack them with tar jxf, cd to the each unpacked directory,
and
build the package with “./mingwPORT.sh”.

If you get “wget: command not found”, you will first need to download
wget-1.9.1-mingwPORT.tar.gz, unpack it with tar zxf, and copy
mingwPORT/wget.exe to /usr/local/bin.

I also needed an extra step to work around a problem in automake:

aclocal_exe=which aclocal
sed s,C:/,/C/,g $aclocal_exe > aclocal.tmp
mv -f aclocal.tmp $aclocal_exe

You may need to repeat the above step, substituting “autoconf” for
“aclocal”.

You may need to start a new MSYS shell for the new versions of the above
tools to be seen.

These added requirements are also required for building from the svn
repository. They are needed because the Windows versions of libtool do
not
know how to track interlibrary dependencies.

Let me know if these instructions work or if they need corrections.
When we
get a set that works, I will add them to the wiki.

– Don W.

Thanks Michael, it worked flawlessly

IIRC: The “standard C” way to do this is:

In one, and only one, .cc file, do at the top level (not in any class,
method, or function definition), e.g.:

int foo = 0;

then in the .h file do:

extern int foo;

and you should be able to access ‘foo’ from any code the includes
that .h file.

Don - I ran through all of these updates (autoconf 2.59, automake 1.9.5,
libtool 1.5.22) using the mingwPORT as you suggested. However, I
couldn’t get your “sed” command to work properly so just edited
“aclocal” and “autoconf” manually to replace “C:” with “/C/”. After
doing all of this, I did have to delete my gnuradio-3.1.2 directory and
start over from “tar -zxf gnuradio-3.1.2.tar.gz”, but from there on I
just followed the current instructions. Everything seems to have built
properly and things seem to be working.

Two other things:

  1. I recalled mention of NumPy as a requirement vice Numeric so
    installed it a while back, but notice your instructions still reference
    Numeric. Is NumPy not required?

  2. I happened to notice the required SDL version changed from 1.2.11 to
    1.2.13 so it might be worth highlighting that fact in the instructions.

Thanks a lot for your help!

Rob


Message: 6
Date: Sat, 12 Apr 2008 19:21:47 -0400
From: “Don W.” [email protected]
Subject: Re: [Discuss-gnuradio] MinGW install problem
To: “Walker, Robert CIV NSWC Crane, WCE Aviation Systems S.”
[email protected], [email protected]
Cc: [email protected]
Message-ID: [email protected]
Content-Type: text/plain; format=flowed; charset=“UTF-8”;
reply-type=original

Don W. wrote:

GNU Radio 3.1.2 requires several MSYS/MinGW packages that were not
required by earlier releases. You need the following:

  • autoconf 2.59 (or later)
  • automake 1.9.5 (or later)
  • libtool 1.5 (or later)

I also needed an extra step to work around a problem in automake:

aclocal_exe=which aclocal
sed s,C:/,/C/,g $aclocal_exe > aclocal.tmp mv -f aclocal.tmp
$aclocal_exe

You may need to repeat the above step, substituting “autoconf” for
“aclocal”.

You may need to start a new MSYS shell for the new versions of the above
tools to be seen.

These added requirements are also required for building from the svn
repository. They are needed because the Windows versions of libtool do
not know how to track interlibrary dependencies.

Let me know if these instructions work or if they need corrections.
When we get a set that works, I will add them to the wiki.

– Don W.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs