Migrations broken on trunk?

Just got an odd error running migrations off of a new trunk today. Is
this my fault is there a bug right now?

rake db:migrate --trace
(in /home/magneticworld)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
undefined method instantiate_observers' for ActiveRecord::Base:Class /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/base.rb:1129:inmethod_missing’
/home/magneticworld/config/…/vendor/rails/railties/lib/initializer.rb:179:in
load_observers' /home/magneticworld/config/../vendor/rails/railties/lib/initializer.rb:105:inprocess’
/home/magneticworld/config/…/vendor/rails/railties/lib/initializer.rb:42:in
`run’
/home/magneticworld/config/…/config/environment.rb:10

On Tue, 2006-08-08 at 20:26 +0200, Alex W. wrote:

/usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.2/lib/active_record/base.rb:1129:in
method_missing' /home/magneticworld/config/../vendor/rails/railties/lib/initializer.rb:179:inload_observers’
/home/magneticworld/config/…/vendor/rails/railties/lib/initializer.rb:105:in
process' /home/magneticworld/config/../vendor/rails/railties/lib/initializer.rb:42:inrun’
/home/magneticworld/config/…/config/environment.rb:10


you might want to be more specific…

rake db:migrate RAILS_ENV=production --trace # adj as necessary

does the db exist for your RAILS_ENV ?

Craig

That’s a gem, not trunk. /usr/local/lib/ruby/gems …

-Jonathan.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs